Bug 1268495 - Huge cursor in Wayland desktop and login screen on HiDPI device (MacBook Pro Retina)
Huge cursor in Wayland desktop and login screen on HiDPI device (MacBook Pro ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 1265799 (view as bug list)
Depends On:
Blocks: F23FinalFreezeException
  Show dependency treegraph
 
Reported: 2015-10-02 19:08 EDT by Brion Vibber
Modified: 2015-12-25 09 EST (History)
11 users (show)

See Also:
Fixed In Version: mutter-3.18.1-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 17:08:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of gnome wayland desktop with huge cursor (1.74 MB, image/png)
2015-10-02 19:08 EDT, Brion Vibber
no flags Details
Huge Cursor in GTK3 Apps under Wayland (980.37 KB, application/octet-stream)
2015-12-25 09:27 EST, Anass Ahmed
no flags Details

  None (edit)
Description Brion Vibber 2015-10-02 19:08:02 EDT
Created attachment 1079550 [details]
Screenshot of gnome wayland desktop with huge cursor

Description of problem:

In Fedora 23 beta installed on a Retina MacBook Pro (2560x1600 HiDPI screen), the mouse cursor is much larger than expected under a Wayland session (including on the login screen if not using a Wayland desktop session).

This behavior appeared after installing software updates.


Version-Release number of selected component (if applicable):



How reproducible:

Always


Steps to Reproduce:
1. Turn on computer, wait for login screen
2. Optionally log in with a Wayland GNOME session
3. Look at the mouse cursor

Actual results:

Mouse cursor is about twice the width/height it should be. See attached screenshot.


Expected results:

Mouse cursor should be expected size.


Additional info:

If I move the mouse cursor over the Gnome settings 'Detail' window, the cursor returns to normal size. If I put it over the background, the shell menu, anything on the shell 'activities' view, Firefox, etc, it's right back to double-sized.
Comment 1 Andreas Nilsson 2015-10-12 06:39:18 EDT
I've seen this on my Lenovo Yoga Pro too.
Like Brion, I always see it in GDM, but also if I log in to the wayland session. If I log in to the regular session it doesn't happen.
Comment 2 Fedora Blocker Bugs Application 2015-10-12 06:47:01 EDT
Proposed as a Freeze Exception for 23-final by Fedora user andreasn using the blocker tracking app because:

 It would be good to have this fixed in the final release.
As it is now, everyone using Workstation with a hidpi screen will have a really bad first experience on first boot (and every boot after that).
Comment 3 Fabio Valentini 2015-10-12 08:18:00 EDT
Well, I think this bug should be considered a duplicate of a bug that I already reported 1-2 weeks prior to this one, but has not got _any_attention.

https://bugzilla.redhat.com/show_bug.cgi?id=1265799
Comment 4 Michael Catanzaro 2015-10-12 09:50:12 EDT
*** Bug 1265799 has been marked as a duplicate of this bug. ***
Comment 5 Michael Catanzaro 2015-10-12 09:51:23 EDT
From the original bug: "cursor is not only scaled up to 2x pixel-size, but 4x pixel-size for gnome-shell and xwayland clients (e.g. google chrome). hovering over wayland clients (regular gnome applications, e.g. nautilus, gnome-terminal, etc.), the cursor returns to correct size (scaled to 2x)."
Comment 6 Tim Flink 2015-10-12 13:12:02 EDT
Discussed during the 2015-10-12 blocker review meeting [1]:

Not enough to be a blocker but clearly an annoyance for some wayland users. A tested fix would be considered for inclusion in F23 final.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-12/f23-blocker-review.2015-10-12-16.01.html
Comment 7 Fedora Update System 2015-10-15 17:26:37 EDT
yelp-xsl-3.18.1-1.fc23 yelp-3.18.1-1.fc23 webkitgtk4-2.10.2-1.fc23 vte3-0.36.5-1.fc23 vte291-0.42.1-1.fc23 vinagre-3.18.1-1.fc23 totem-3.18.1-1.fc23 simple-scan-3.18.1-1.fc23 rygel-0.28.1-1.fc23 polari-3.18.1-1.fc23 pinentry-0.9.6-3.fc23 pango-1.38.1-1.fc23 orca-3.18.1-1.fc23 nautilus-3.18.1-1.fc23 mutter-3.18.1-2.fc23 libsoup-2.52.1-1.fc23 librsvg2-2.40.11-1.fc23 libgweather-3.18.1-1.fc23 libappstream-glib-0.5.1-2.fc23 iagno-3.18.1-1.fc23 gvfs-1.26.1.1-1.fc23 gucharmap-3.18.1-1.fc23 gtksourceview3-3.18.1-1.fc23 gtk3-3.18.2-1.fc23 gnome-weather-3.18.1-1.fc23 gnome-user-docs-3.18.1-1.fc23 gnome-todo-3.18.1-1.fc23 gnome-terminal-3.18.1-1.fc23 gnome-taquin-3.18.1.1-1.fc23 gnome-sudoku-3.18.1-1.fc23 gnome-sound-recorder-3.18.1-1.fc23 gnome-software-3.18.2-1.fc23 gnome-shell-extensions-3.18.1-1.fc23 gnome-shell-3.18.1-1.fc23 gnome-settings-daemon-3.18.1-1.fc23 gnome-session-3.18.1.2-1.fc23 gnome-photos-3.18.1-1.fc23 gnome-online-accounts-3.18.1-1.fc23 gnome-nibbles-3.18.1-1.fc23 gnome-mines-3.18.1-1.fc23 gnome-maps-3.18.1-1.fc23 gnome-logs-3.18.1-1.fc23 gnome-klotski-3.18.1-1.fc23 gnome-getting-started-docs-3.18.1-1.fc23 gnome-documents-3.18.1-1.fc23 gnome-disk-utility-3.18.1-1.fc23 gnome-devel-docs-3.18.1-1.fc23 gnome-desktop3-3.18.1-1.fc23 gnome-characters-3.18.1-1.fc23 gnome-calculator-3.18.1-1.fc23 gnome-builder-3.18.1-1.fc23 gnome-boxes-3.18.1-1.fc23 gnome-2048-3.18.1-1.fc23 glib2-2.46.1-1.fc23 glib-networking-2.46.1-1.fc23 gedit-3.18.1-1.fc23 four-in-a-row-3.18.1-1.fc23 evolution-ews-3.18.1-1.fc23 evolution-data-server-3.18.1-1.fc23 evolution-3.18.1-1.fc23 empathy-3.12.11-1.fc23 devhelp-3.18.1-1.fc23 dconf-editor-3.18.1-1.fc23 control-center-3.18.1-1.fc23 clutter-gtk-1.6.6-1.fc23 clutter-gst3-3.0.14-2.fc23 clutter-1.24.2-1.fc23 cheese-3.18.1-1.fc23 caribou-0.4.19-1.fc23 bijiben-3.18.1-1.fc23 baobab-3.18.1-2.fc23 at-spi2-core-2.18.1-1.fc23 at-spi2-atk-2.18.1-1.fc23 appstream-data-23-6.fc23 aisleriot-3.18.1-1.fc23 abattis-cantarell-fonts-0.0.17.2-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-13e545ec3e
Comment 8 Fedora Update System 2015-10-15 23:02:40 EDT
abattis-cantarell-fonts-0.0.17.2-1.fc23, aisleriot-3.18.1-1.fc23, appstream-data-23-6.fc23, at-spi2-atk-2.18.1-1.fc23, at-spi2-core-2.18.1-1.fc23, baobab-3.18.1-2.fc23, bijiben-3.18.1-1.fc23, caribou-0.4.19-1.fc23, cheese-3.18.1-1.fc23, clutter-1.24.2-1.fc23, clutter-gst3-3.0.14-2.fc23, clutter-gtk-1.6.6-1.fc23, control-center-3.18.1-1.fc23, dconf-editor-3.18.1-1.fc23, devhelp-3.18.1-1.fc23, empathy-3.12.11-1.fc23, evolution-3.18.1-1.fc23, evolution-data-server-3.18.1-1.fc23, evolution-ews-3.18.1-1.fc23, four-in-a-row-3.18.1-1.fc23, gedit-3.18.1-1.fc23, glib-networking-2.46.1-1.fc23, glib2-2.46.1-1.fc23, gnome-2048-3.18.1-1.fc23, gnome-boxes-3.18.1-1.fc23, gnome-builder-3.18.1-1.fc23, gnome-calculator-3.18.1-1.fc23, gnome-characters-3.18.1-1.fc23, gnome-desktop3-3.18.1-1.fc23, gnome-devel-docs-3.18.1-1.fc23, gnome-disk-utility-3.18.1-1.fc23, gnome-documents-3.18.1-1.fc23, gnome-getting-started-docs-3.18.1-1.fc23, gnome-klotski-3.18.1-1.fc23, gnome-logs-3.18.1-1.fc23, gnome-maps-3.18.1-1.fc23, gnome-mines-3.18.1-1.fc23, gnome-nibbles-3.18.1-1.fc23, gnome-online-accounts-3.18.1-1.fc23, gnome-photos-3.18.1-1.fc23, gnome-session-3.18.1.2-1.fc23, gnome-settings-daemon-3.18.1-1.fc23, gnome-shell-3.18.1-1.fc23, gnome-shell-extensions-3.18.1-1.fc23, gnome-software-3.18.2-1.fc23, gnome-sound-recorder-3.18.1-1.fc23, gnome-sudoku-3.18.1-1.fc23, gnome-taquin-3.18.1.1-1.fc23, gnome-terminal-3.18.1-1.fc23, gnome-todo-3.18.1-1.fc23, gnome-user-docs-3.18.1-1.fc23, gnome-weather-3.18.1-1.fc23, gtk3-3.18.2-1.fc23, gtksourceview3-3.18.1-1.fc23, gucharmap-3.18.1-1.fc23, gvfs-1.26.1.1-1.fc23, iagno-3.18.1-1.fc23, libappstream-glib-0.5.1-2.fc23, libgweather-3.18.1-1.fc23, librsvg2-2.40.11-1.fc23, libsoup-2.52.1-1.fc23, mutter-3.18.1-2.fc23, nautilus-3.18.1-1.fc23, orca-3.18.1-1.fc23, pango-1.38.1-1.fc23, pinentry-0.9.6-3.fc23, polari-3.18.1-1.fc23, rygel-0.28.1-1.fc23, simple-scan-3.18.1-1.fc23, totem-3.18.1-1.fc23, vinagre-3.18.1-1.fc23, vte291-0.42.1-1.fc23, vte3-0.36.5-1.fc23, webkitgtk4-2.10.2-1.fc23, yelp-3.18.1-1.fc23, yelp-xsl-3.18.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update abattis-cantarell-fonts aisleriot appstream-data at-spi2-atk at-spi2-core baobab bijiben caribou cheese clutter clutter-gst3 clutter-gtk control-center dconf-editor empathy evolution evolution-data-server evolution-ews four-in-a-row gedit glib-networking glib2 gnome-2048 gnome-boxes gnome-builder gnome-calculator gnome-characters gnome-desktop3 gnome-devel-docs gnome-disk-utility gnome-documents gnome-getting-started-docs gnome-klotski gnome-logs gnome-maps gnome-mines gnome-nibbles gnome-online-accounts gnome-photos gnome-session gnome-settings-daemon gnome-shell gnome-shell-extensions gnome-software gnome-sound-recorder gnome-sudoku gnome-taquin gnome-terminal gnome-todo gnome-user-docs gnome-weather gtk3 gtksourceview3 gucharmap gvfs iagno libappstream-glib libgweather librsvg2 libsoup mutter nautilus orca pango pinentry polari rygel simple-scan devhelp totem vinagre vte291 vte3 webkitgtk4 yelp yelp-xsl'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13e545ec3e
Comment 9 Fedora Update System 2015-10-19 17:08:37 EDT
abattis-cantarell-fonts-0.0.17.2-1.fc23, aisleriot-3.18.1-1.fc23, appstream-data-23-6.fc23, at-spi2-atk-2.18.1-1.fc23, at-spi2-core-2.18.1-1.fc23, baobab-3.18.1-2.fc23, bijiben-3.18.1-1.fc23, caribou-0.4.19-1.fc23, cheese-3.18.1-1.fc23, clutter-1.24.2-1.fc23, clutter-gst3-3.0.14-2.fc23, clutter-gtk-1.6.6-1.fc23, control-center-3.18.1-1.fc23, dconf-editor-3.18.1-1.fc23, devhelp-3.18.1-1.fc23, empathy-3.12.11-1.fc23, evolution-3.18.1-1.fc23, evolution-data-server-3.18.1-1.fc23, evolution-ews-3.18.1-1.fc23, four-in-a-row-3.18.1-1.fc23, gedit-3.18.1-1.fc23, glib-networking-2.46.1-1.fc23, glib2-2.46.1-1.fc23, gnome-2048-3.18.1-1.fc23, gnome-boxes-3.18.1-1.fc23, gnome-builder-3.18.1-1.fc23, gnome-calculator-3.18.1-1.fc23, gnome-characters-3.18.1-1.fc23, gnome-desktop3-3.18.1-1.fc23, gnome-devel-docs-3.18.1-1.fc23, gnome-disk-utility-3.18.1-1.fc23, gnome-documents-3.18.1-1.fc23, gnome-getting-started-docs-3.18.1-1.fc23, gnome-klotski-3.18.1-1.fc23, gnome-logs-3.18.1-1.fc23, gnome-maps-3.18.1-1.fc23, gnome-mines-3.18.1-1.fc23, gnome-nibbles-3.18.1-1.fc23, gnome-online-accounts-3.18.1-1.fc23, gnome-photos-3.18.1-1.fc23, gnome-session-3.18.1.2-1.fc23, gnome-settings-daemon-3.18.1-1.fc23, gnome-shell-3.18.1-1.fc23, gnome-shell-extensions-3.18.1-1.fc23, gnome-software-3.18.2-1.fc23, gnome-sound-recorder-3.18.1-1.fc23, gnome-sudoku-3.18.1-1.fc23, gnome-taquin-3.18.1.1-1.fc23, gnome-terminal-3.18.1-1.fc23, gnome-todo-3.18.1-1.fc23, gnome-user-docs-3.18.1-1.fc23, gnome-weather-3.18.1-1.fc23, gtk3-3.18.2-1.fc23, gtksourceview3-3.18.1-1.fc23, gucharmap-3.18.1-1.fc23, gvfs-1.26.1.1-1.fc23, iagno-3.18.1-1.fc23, libappstream-glib-0.5.1-2.fc23, libgweather-3.18.1-1.fc23, librsvg2-2.40.11-1.fc23, libsoup-2.52.1-1.fc23, mutter-3.18.1-2.fc23, nautilus-3.18.1-1.fc23, orca-3.18.1-1.fc23, pango-1.38.1-1.fc23, pinentry-0.9.6-3.fc23, polari-3.18.1-1.fc23, rygel-0.28.1-1.fc23, simple-scan-3.18.1-1.fc23, totem-3.18.1-1.fc23, vinagre-3.18.1-1.fc23, vte291-0.42.1-1.fc23, vte3-0.36.5-1.fc23, webkitgtk4-2.10.2-1.fc23, yelp-3.18.1-1.fc23, yelp-xsl-3.18.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Anass Ahmed 2015-12-25 09:27 EST
Created attachment 1109412 [details]
Huge Cursor in GTK3 Apps under Wayland

I don't know if it's the same issue, but it's related to it.

I see a huge cursor on Nautilus, GNOME Terminal, and Evince in comparison with Firefox as you can see in the attached video. My Laptop is 14" inch Full HD (1920 x 1080).

In addition to that, the cursor looks like stuck when changing shapes (re-sizing window shape, normal shape, pointer shape).

Affected Version: 

Fedora 23

gnome-shell-3.18.3-1.fc23.x86_64
gnome-session-wayland-session-3.18.1.2-2.fc23.x86_64
libwayland-server-1.9.0-1.fc23.x86_64
xorg-x11-server-Xwayland-1.18.0-2.fc23.x86_64
libwayland-cursor-1.9.0-1.fc23.x86_64

Note You need to log in before you can comment on or make changes to this bug.