Bug 1265893 - Perf: Getting bad performance while doing ls
Perf: Getting bad performance while doing ls
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
: 1265879 (view as bug list)
Depends On:
Blocks: 1267149 1267823
  Show dependency treegraph
 
Reported: 2015-09-24 02:08 EDT by Pranith Kumar K
Modified: 2016-06-16 09:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1267149 1267823 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:38:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-09-24 02:08:19 EDT
Description of problem:

We found that readdirp is taking a lot of time because of unnecessary lstats and readlinks and lgetxattrs that can be avoided. This bug will track that part of the bad performance.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Pranith Kumar K 2015-09-24 02:08:43 EDT
*** Bug 1265879 has been marked as a duplicate of this bug. ***
Comment 2 Raghavendra Bhat 2015-09-28 03:19:19 EDT
http://review.gluster.org/12222 has been merged.

Pranith, can you please backport it to 3.7? Also, if its needed for 3.6 as well (I think its needed) please backport it to 3.6 as well.
Comment 3 Vijay Bellur 2016-01-14 06:02:07 EST
REVIEW: http://review.gluster.org/12271 (dht: improving readdir performance) posted (#2) for review on master by Sakshi Bansal
Comment 4 Vijay Bellur 2016-04-18 12:11:05 EDT
REVIEW: http://review.gluster.org/12271 (dht: improving readdir performance) posted (#3) for review on master by Sakshi Bansal
Comment 5 Vijay Bellur 2016-04-25 13:55:00 EDT
REVIEW: http://review.gluster.org/12271 (dht: improving readdir performance) posted (#4) for review on master by Sakshi Bansal
Comment 6 Niels de Vos 2016-06-16 09:38:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.