Bug 1267823 - Perf: Getting bad performance while doing ls
Perf: Getting bad performance while doing ls
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: posix (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 1265893
Blocks: 1267149
  Show dependency treegraph
 
Reported: 2015-10-01 03:29 EDT by Pranith Kumar K
Modified: 2015-10-14 06:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1265893
Environment:
Last Closed: 2015-10-14 06:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-10-01 03:29:46 EDT
+++ This bug was initially created as a clone of Bug #1265893 +++

Description of problem:

We found that readdirp is taking a lot of time because of unnecessary lstats and readlinks and lgetxattrs that can be avoided. This bug will track that part of the bad performance.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Pranith Kumar K on 2015-09-24 02:08:43 EDT ---



--- Additional comment from Raghavendra Bhat on 2015-09-28 03:19:19 EDT ---

http://review.gluster.org/12222 has been merged.

Pranith, can you please backport it to 3.7? Also, if its needed for 3.6 as well (I think its needed) please backport it to 3.6 as well.
Comment 1 Pranith Kumar K 2015-10-14 06:27:30 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 2 Pranith Kumar K 2015-10-14 06:37:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.