Bug 1265904 - 'requres --auto' is missing in help message for attach --servicelevel
Summary: 'requres --auto' is missing in help message for attach --servicelevel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.8
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: pre-dev-freeze
: ---
Assignee: vritant
QA Contact: John Sefler
URL:
Whiteboard:
: 1283607 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-24 07:03 UTC by qianzhan
Modified: 2016-05-10 20:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-10 20:37:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0797 0 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-01-06 16:31:50 UTC

Description qianzhan 2015-09-24 07:03:01 UTC
Description of problem:
'requres --auto' is missing in help message for attach --servicelevel

Version-Release number of selected component (if applicable):
subscription management rules: 5.16
subscription-manager: 1.15.9-10.el7

How reproducible:
Always.

Steps to Reproduce:
1. Register and auto-attach.
[root@dhcp-128-120 ~]# subscription-manager register --auto-attach
Registering to: hp-sl2x170zg6-01.rhts.eng.bos.redhat.com:443/rhsm
Username: admin
Password: 
The system has been registered with ID: 39599078-eef9-4791-b93f-3f293afae526 

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

2. Check help message for 'attach --servicelevel'
[root@dhcp-128-120 ~]# subscription-manager attach --help | grep 'servicelevel' -A3
  --servicelevel=SERVICE_LEVEL
                        service level to apply to this system
  --file=FILE           A file from which to read pool IDs. If a hyphen is
                        provided, pool IDs will be read from stdin.


Actual results:
As step 2.

Expected results:
The output of step 2 should be like:
# subscription-manager attach --help | grep 'servicelevel' -A3
  --servicelevel=SERVICE_LEVEL
                        service level to apply to this system, requires --auto

Additional info:
Option '--servicelevel' is only used when 'attach --auto':

[root@dhcp-128-120 ~]# subscription-manager attach --auto --servicelevel=premium

Service level set to: premium

Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@dhcp-128-120 ~]# subscription-manager remove --all
1 subscription removed at the server.
1 local certificate has been deleted.
[root@dhcp-128-120 ~]# subscription-manager attach --pool=8a90c29d4fa60278014fcecad5e9022e --servicelevel=premium
Error: The --servicelevel option cannot be used when specifying pools.

Comment 2 John Sefler 2015-09-24 21:01:42 UTC
deferring for consideration in rhel-7.3.0 due to schedule and severity

This requires a new string and we are currently past String Freeze.

Comment 4 Barnaby Court 2015-11-20 16:18:10 UTC
High priority to get it in before the string freeze

Comment 7 vritant 2015-11-24 20:54:14 UTC
*** Bug 1283607 has been marked as a duplicate of this bug. ***

Comment 9 Shwetha Kallesh 2015-12-09 18:15:26 UTC
Marking verified!!

[root@pogo-cn1100-01 yum.repos.d]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.11-1
subscription management rules: 5.15
subscription-manager: 1.16.6-1.el6
python-rhsm: 1.16.4-1.el6

[root@pogo-cn1100-01 yum.repos.d]# subscription-manager attach --help | grep 'servicelevel' -A3
  --servicelevel=SERVICE_LEVEL
                        Automatically attach only subscriptions matching the
                        specified service level; only used with --auto

Comment 11 errata-xmlrpc 2016-05-10 20:37:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0797.html


Note You need to log in before you can comment on or make changes to this bug.