Bug 126591 - rpm is missing dependencies in its spec file
rpm is missing dependencies in its spec file
Status: CLOSED DUPLICATE of bug 147013
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 12:43 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-06-23 12:43:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
rpm is missing dependencies in its spec file. The following patch
fixes it:

--- working/rpm/rpm.spec        2004-06-14 15:32:22.000000000 -0400
+++ /opt/specs/rpm.spec 2004-06-17 17:23:58.000000000 -0400
@@ -40,6 +40,9 @@
 BuildRequires: beecrypt-devel >= 3.0.1
 Requires: beecrypt >= 3.0.1
                                                                     
          
+BuildRequires: libselinux-devel
+Requires: libselinux
+
 # XXX Red Hat 5.2 has not bzip2 or python
 %if %{with_bzip2}
 BuildRequires: bzip2 >= 0.9.0c-2
@@ -48,6 +51,9 @@
 BuildRequires: python-devel >= %{with_python_version}
 %endif
                                                                     
          
+BuildRequires: readline-devel, ncurses-devel
+Requires: readline, ncurses
+
 BuildRoot: %{_tmppath}/%{name}-root
                                                                     
          
 %description

Version-Release number of selected component (if applicable):
rpm-4.3.2-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps readline-devel ncurses-devel libselinux-devel
2. rpmbuild -bb /usr/src/redhat/SPECS/rpm.spec

Additional info:
Comment 1 Bill Nottingham 2004-08-05 17:43:05 EDT
You don't need to explicitly require readline, ncurses, etc if it's
linked in.
Comment 2 Steve Grubb 2004-08-05 20:01:14 EDT
Ahh, but it is linked in. This entry in the changelog is when it
became necessary:

* Tue Jun  8 2004 Jeff Johnson <jbj@jbj.org> 4.3.2-0.2
- lua embedded in rpmio.
- use lua to identify desired selinux file context regexes.

Without that...libselinux was all that was missing.
Comment 3 Jeff Johnson 2005-02-07 19:09:19 EST

*** This bug has been marked as a duplicate of 147013 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.