Bug 147013 - lua requires readline
Summary: lua requires readline
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 126591 130738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-02-03 18:15 UTC by Mark Hatle
Modified: 2016-03-27 14:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-12 16:33:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove the usage of newline from lua (1.74 KB, patch)
2005-02-03 18:18 UTC, Mark Hatle
no flags Details | Diff

Description Mark Hatle 2005-02-03 18:15:30 UTC
lua requires readline.  Won't compile on a system without readline
installed.

Comment 1 Mark Hatle 2005-02-03 18:18:06 UTC
Created attachment 110603 [details]
Remove the usage of newline from lua

This removes the linking and usage of readline from lua in RPM.

The patch is generated against rpm-4_3 branch on 050201.

This allows RPM to compile and function, I have not performed any QA to see if
lua still functions as expected.

Comment 2 Jeff Johnson 2005-02-07 20:34:08 UTC
*** Bug 130738 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2005-02-08 00:09:32 UTC
*** Bug 126591 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2006-02-12 16:33:42 UTC
Fixed in rpm cvs, shpould be in rpm-4.4.5-0.10 when built.


Note You need to log in before you can comment on or make changes to this bug.