Bug 126596 - shadow-utils is missing dependencies
shadow-utils is missing dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eido INOUE
David Lawrence
:
: 123748 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-23 13:06 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 08:49:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-06-23 13:06:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
shadow-utils is missing build dependencies:

--- working/shadow-utils/shadow-utils.spec      2004-03-30
16:27:41.000000000 -0500
+++ /opt/specs/shadow-utils.spec        2004-05-22 18:18:17.000000000
-0400
@@ -32,7 +32,9 @@
 Patch12: shadow-4.0.3-uninitialized.patch
 License: BSD
 Group: System Environment/Base
-BuildPrereq: autoconf, automake, libtool
+BuildPrereq: autoconf, automake, libtool, gettext
+BuildRequires: libselinux-devel
+Requires: libselinux
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 Obsoletes: adduser
                                                                     
          


Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-23

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps libselinux-devel gettext
2. rpmbuild -bb /usr/src/redhat/SPECS/shadow-utils.spec
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-08-05 17:46:00 EDT
Requires: libselinux is superfluous.
Comment 2 Warren Togami 2004-08-24 08:41:01 EDT
*** Bug 123748 has been marked as a duplicate of this bug. ***
Comment 3 Warren Togami 2004-08-24 08:49:08 EDT
should be in rawhide soon

Note You need to log in before you can comment on or make changes to this bug.