Bug 1266013 - need to remove a few bogus .R macros of mountstats man page
Summary: need to remove a few bogus .R macros of mountstats man page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-24 10:13 UTC by Yongcheng Yang
Modified: 2016-11-04 05:00 UTC (History)
3 users (show)

Fixed In Version: nfs-utils-1.3.0-0.25.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:00:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description Yongcheng Yang 2015-09-24 10:13:49 UTC
Description of problem:
[root@hp-dl388g8-17 ~]# man mountstats >/dev/null
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
[root@hp-dl388g8-17 ~]# 

Version-Release number of selected component (if applicable):
nfs-utils-1.3.0-0.20.el7

How reproducible:
100%

Steps to Reproduce:
1. man mountstats >/dev/null
2.
3.

Additional info:
Here is the upstream commit to fix this issue
commit f2efa15ef8c083926791195ed1037fd47a5e4e41
Author: Scott Mayhew <smayhew@redhat.com>
Date:   Wed Sep 16 11:19:41 2015 -0400

    mountstats.man:  Remove a few bogus .R macros
    
    These have no effect on the rendering of the man page, but they do cause
    the following error if you try to pipe or redirect the output:
    
    `R' is a string (producing the registered sign), not a macro.
    
    Signed-off-by: Scott Mayhew <smayhew@redhat.com>
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 3 Steve Dickson 2016-05-02 19:26:40 UTC
*** Bug 1263966 has been marked as a duplicate of this bug. ***

Comment 5 Yongcheng Yang 2016-05-18 12:18:13 UTC
Verified with nfs-utils-1.3.0-0.25.el7
[root@hp-dl585g7-04 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.25.el7.x86_64
[root@hp-dl585g7-04 ~]# man mountstats >/dev/null
[root@hp-dl585g7-04 ~]#

Reproduced with previous version.
[root@hp-dl585g7-04 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.21.el7.x86_64
[root@hp-dl585g7-04 ~]# man mountstats >/dev/null
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
[root@hp-dl585g7-04 ~]# 

Move to VERIFIED and continue to run the automatic case in the future.

Comment 6 Yongcheng Yang 2016-05-19 07:23:55 UTC
Just noticed that Bug 1263966 is duplicated to this one.
And the patch mentioned in Bug 1263966 Comment 0 has not been included yet.

So changed to ASSIGNED and please correct me if there is any concern.

commit 8c7d7fe5577b059130d472d4145a09cf9d4a7ea2
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Aug 10 09:58:01 2015 -0400

    mountstats.man: fixed typo in man page


[root@hp-dl585g7-04 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.26.el7.x86_64
[root@hp-dl585g7-04 ~]# man mountstats | col -b | grep -e "-s|--since"
	      interval since the previous report.  This may not be used with the -f|--file or -s|--since options.
[root@hp-dl585g7-04 ~]#

Comment 7 Steve Dickson 2016-05-19 12:55:49 UTC
(In reply to Yongcheng Yang from comment #6)
> Just noticed that Bug 1263966 is duplicated to this one.
> And the patch mentioned in Bug 1263966 Comment 0 has not been included yet.
> 
> So changed to ASSIGNED and please correct me if there is any concern.
> 
> commit 8c7d7fe5577b059130d472d4145a09cf9d4a7ea2
> Author: Steve Dickson <steved@redhat.com>
> Date:   Mon Aug 10 09:58:01 2015 -0400
> 
>     mountstats.man: fixed typo in man page
Per the request in comment 9 of bug 1215808
    https://bugzilla.redhat.com/show_bug.cgi?id=1215808#c9

Another bz should be opened to deal with this one.

Since "bogus .R macros" have been removed, this
bz should go back to VERIFIED

Comment 8 Yongcheng Yang 2016-05-20 00:28:09 UTC
(In reply to Steve Dickson from comment #7)
> (In reply to Yongcheng Yang from comment #6)
> > Just noticed that Bug 1263966 is duplicated to this one.
> > And the patch mentioned in Bug 1263966 Comment 0 has not been included yet.
> > 
> > So changed to ASSIGNED and please correct me if there is any concern.
> > 
> > commit 8c7d7fe5577b059130d472d4145a09cf9d4a7ea2
> > Author: Steve Dickson <steved@redhat.com>
> > Date:   Mon Aug 10 09:58:01 2015 -0400
> > 
> >     mountstats.man: fixed typo in man page
> Per the request in comment 9 of bug 1215808
>     https://bugzilla.redhat.com/show_bug.cgi?id=1215808#c9
> 
> Another bz should be opened to deal with this one.

OK, just reopen the Bug 1263966 to trace this issue.

> 
> Since "bogus .R macros" have been removed, this
> bz should go back to VERIFIED

Move this bug to VERIFIED according to the test result in comment 5

Comment 11 errata-xmlrpc 2016-11-04 05:00:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.