Bug 1263966 - typo in mountstats man page that should not contain "-s|--since"
Summary: typo in mountstats man page that should not contain "-s|--since"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-17 08:16 UTC by Yongcheng Yang
Modified: 2016-11-04 05:00 UTC (History)
1 user (show)

Fixed In Version: nfs-utils-1.3.0-0.27.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1263968 (view as bug list)
Environment:
Last Closed: 2016-11-04 05:00:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2383 0 normal SHIPPED_LIVE nfs-utils bug fix and enhancement update 2016-11-03 13:53:02 UTC

Description Yongcheng Yang 2015-09-17 08:16:21 UTC
Description of problem:
In the mountstats man page, option "-S sincefile, --since sincefile" can be mostly written as "-S|--since", but there is one place it shows as "-s|--since", so need to modify it to keep them consistency.

Version-Release number of selected component (if applicable):
nfs-utils-1.3.0-0.20.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. man mountstats | col -b | grep -e "-s|--since"

Actual results:
[root@hp-dl380pg8-01 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.20.el7.x86_64
[root@hp-dl380pg8-01 ~]# man mountstats | col -b | grep -e "-s|--since"
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ above error is another bz
	      or -s|--since options.
[root@hp-dl380pg8-01 ~]# 


Expected results:
All be written as "-S|--since"

Additional info:
There already has an upstream commit to fix it:
commit 8c7d7fe5577b059130d472d4145a09cf9d4a7ea2
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Aug 10 09:58:01 2015 -0400

    mountstats.man: fixed typo in man page
    
    Signed-off-by: Steve Dickson <steved@redhat.com>

Comment 3 Steve Dickson 2016-05-02 19:26:40 UTC

*** This bug has been marked as a duplicate of bug 1266013 ***

Comment 5 Yongcheng Yang 2016-05-23 07:11:46 UTC
Verified with nfs-utils-1.3.0-0.27.el7
Move to VERIFIED and continue to run the automatic case.

[root@hp-dl380pg8-14 ~]# rpm -q nfs-utils
nfs-utils-1.3.0-0.21.el7.x86_64
[root@hp-dl380pg8-14 ~]#  man mountstats | col -b | grep -e "-s|--since"
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
`R' is a string (producing the registered sign), not a macro.
	      ous report.  This may not be used with the -f|--file or -s|--since options.
[root@hp-dl380pg8-14 ~]# rpm -Uvh nfs-utils-1.3.0-0.27.el7.x86_64.rpm 
Preparing...                          ################################# [100%]
Updating / installing...
   1:nfs-utils-1:1.3.0-0.27.el7       ################################# [ 50%]
Cleaning up / removing...
   2:nfs-utils-1:1.3.0-0.21.el7       ################################# [100%]
[root@hp-dl380pg8-14 ~]# man mountstats | col -b | grep -e "-s|--since"
[root@hp-dl380pg8-14 ~]#

Comment 7 errata-xmlrpc 2016-11-04 05:00:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2383.html


Note You need to log in before you can comment on or make changes to this bug.