Bug 1266029 - TripleO should use pymysql database driver since Liberty
TripleO should use pymysql database driver since Liberty
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Emilien Macchi
Ofer Blaut
: Triaged
Depends On: 1266027
Blocks: 1093829 1266028 1266032
  Show dependency treegraph
 
Reported: 2015-09-24 06:50 EDT by Ihar Hrachyshka
Modified: 2016-04-07 17:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.9-1.el7ost instack-undercloud-2.2.6-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1266027
Environment:
Last Closed: 2016-04-07 17:39:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1499298 None None None Never
OpenStack gerrit 265331 None None None 2016-01-08 11:06 EST
OpenStack gerrit 265334 None None None 2016-01-08 11:10 EST
OpenStack gerrit 284955 None None None 2016-02-25 16:59 EST
OpenStack gerrit 284958 None None None 2016-02-25 17:02 EST

  None (edit)
Description Ihar Hrachyshka 2015-09-24 06:50:16 EDT
+++ This bug was initially created as a clone of Bug #1266027 +++

As of Liberty, openstack gate switched to pymysql driver, so it's better to use it in all openstack installers too.

To switch to the new driver, database_connection string should get driver specifier as in:

database_connection = mysql+pymysql://...127.0.0.1/...
Comment 8 Emilien Macchi 2016-01-08 11:10:50 EST
Undercloud: https://review.openstack.org/265331
Overcloud: https://review.openstack.org/265334

Please review.
Comment 13 James Slagle 2016-03-17 20:11:07 EDT
the patch for the undercloud is in instack-undercloud-2.2.6-1.el7ost.
Comment 17 errata-xmlrpc 2016-04-07 17:39:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.