Bug 1266032 - Packstack should use pymysql database driver since Liberty
Packstack should use pymysql database driver since Liberty
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Ivan Chavero
Yogev Rabl
: TestOnly, Triaged, ZStream
: 1266387 (view as bug list)
Depends On: 1266027 1266028 1266029
Blocks: 1266381
  Show dependency treegraph
 
Reported: 2015-09-24 06:57 EDT by Ihar Hrachyshka
Modified: 2016-04-26 13:01 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.11.dev1692.g1b5e83b.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1266028
Environment:
Last Closed: 2016-04-15 09:46:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
answer-file (42.30 KB, text/plain)
2015-12-07 10:42 EST, Martin Magr
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1499298 None None None Never
OpenStack gerrit 257866 None None None 2015-12-24 15:27 EST
OpenStack gerrit 266888 None None None 2016-01-26 07:51 EST

  None (edit)
Description Ihar Hrachyshka 2015-09-24 06:57:23 EDT
+++ This bug was initially created as a clone of Bug #1266028 +++

+++ This bug was initially created as a clone of Bug #1266027 +++

As of Liberty, openstack gate switched to pymysql driver, so it's better to use it in all openstack installers too.

To switch to the new driver, database_connection string should get driver specifier as in:

database_connection = mysql+pymysql://...127.0.0.1/...
Comment 2 Ihar Hrachyshka 2015-09-25 04:20:29 EDT
*** Bug 1266387 has been marked as a duplicate of this bug. ***
Comment 3 Miguel Angel Ajo 2015-11-12 06:12:29 EST
rising the priority of this, because it does block QoS
Comment 4 Miguel Angel Ajo 2015-11-12 06:13:38 EST
Also upstream uses for all tests the pymsql driver, there are for sure hidden issues with the old one that we don't want to get materialised in support requests.
Comment 6 Martin Magr 2015-12-07 10:42 EST
Created attachment 1103278 [details]
answer-file

Hi,
Regarding https://bugzilla.redhat.com/show_bug.cgi?id=1288968
Please look at the following answer file

Thanks,
Itzik
Comment 7 Martin Magr 2015-12-07 10:44:03 EST
Comment on attachment 1103278 [details]
answer-file

Pardon me, this is a wrong BZ :).
Comment 10 Alvaro Lopez Ortega 2016-01-26 09:56:43 EST
Right. Actually, we identified the old python module as the source of various problems.
Comment 14 Yogev Rabl 2016-04-10 10:27:28 EDT
verified on openstack-packstack-7.0.0-0.14.dev1702.g490e674.el7ost.noarch
Comment 16 errata-xmlrpc 2016-04-15 09:46:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0636.html

Note You need to log in before you can comment on or make changes to this bug.