Bug 1266170 - pungi/lorax/dnf can't build server spin: "no files matched etc/systemd/logind.conf"
pungi/lorax/dnf can't build server spin: "no files matched etc/systemd/logind...
Status: CLOSED DUPLICATE of bug 1262953
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 12:34 EDT by Mark Montague
Modified: 2015-10-02 05:59 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 05:59:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of pungi command showing the lorax error (792.66 KB, text/plain)
2015-09-24 12:34 EDT, Mark Montague
no flags Details

  None (edit)
Description Mark Montague 2015-09-24 12:34:43 EDT
Created attachment 1076634 [details]
Output of pungi command showing the lorax error

Description of problem:

I use pungi under Fedora 23 Beta (fully updated, and with the fix for Bugzilla #1264570) to build DVD images containing repositories for use with Kickstart.  This was working until a "dnf upgrade" sometime between September 9th and September 14th, when pungi started failing due to lorax encountering an error saying "no files matched etc/systemd/logind.conf".


Version-Release number of selected component (if applicable):

fedora-kickstarts-0.23.4-1.fc23.noarch
pungi-4.0.2-1.fc23.noarch
lorax-23.18-1.fc23.x86_64
python-kickstart-2.13-1.fc23.noarch
dnf-1.1.2-2.fc23.noarch


How reproducible:
always


Steps to Reproduce:

1. Either edit the repo lines in /usr/share/spin-kickstarts/fedora-install-server.ks to specify 23 in place of $releasever and x86_64 in place of $basearch, or apply the fix from Bugzilla #1264570.

2. Run the following commands as root:
setenforce 0
pungi --nomacboot --flavor="Kickstart" --name="Fedora" --ver="23" --config=/usr/share/spin-kickstarts/fedora-install-server.ks


Actual results:

DEBUG:pylorax.ltmpl:template line 15: replace #ReserveVT=6 ReserveVT=2 etc/systemd/logind.conf
2015-09-24 15:20:57,635: template command error in runtime-postinstall.tmpl:
template command error in runtime-postinstall.tmpl:
ERROR:pylorax.ltmpl:template command error in runtime-postinstall.tmpl:
2015-09-24 15:20:57,635:   replace #ReserveVT=6 ReserveVT=2 etc/systemd/logind.conf
  replace #ReserveVT=6 ReserveVT=2 etc/systemd/logind.conf
ERROR:pylorax.ltmpl:  replace #ReserveVT=6 ReserveVT=2 etc/systemd/logind.conf
2015-09-24 15:20:57,637:   OSError: no files matched etc/systemd/logind.conf
  OSError: no files matched etc/systemd/logind.conf
ERROR:pylorax.ltmpl:  OSError: no files matched etc/systemd/logind.conf
DEBUG:pylorax.ltmpl:  Traceback (most recent call last):
DEBUG:pylorax.ltmpl:    File "/usr/lib/python3.4/site-packages/pylorax/ltmpl.py", line 289, in replace
DEBUG:pylorax.ltmpl:      raise IOError("no files matched %s" % " ".join(fileglobs))
DEBUG:pylorax.ltmpl:  OSError: no files matched etc/systemd/logind.conf
Traceback (most recent call last):
  File "/usr/sbin/lorax", line 318, in <module>
    main(sys.argv)
  File "/usr/sbin/lorax", line 205, in main
    remove_temp=True, verify=opts.verify)
  File "/usr/lib/python3.4/site-packages/pylorax/__init__.py", line 277, in run
    rb.postinstall()
  File "/usr/lib/python3.4/site-packages/pylorax/treebuilder.py", line 142, in postinstall
    self._runner.run("runtime-postinstall.tmpl", configdir=configdir_path)
  File "/usr/lib/python3.4/site-packages/pylorax/ltmpl.py", line 191, in run
    self._run(commands)
  File "/usr/lib/python3.4/site-packages/pylorax/ltmpl.py", line 210, in _run
    f(*args)
  File "/usr/lib/python3.4/site-packages/pylorax/ltmpl.py", line 289, in replace
    raise IOError("no files matched %s" % " ".join(fileglobs))
OSError: no files matched etc/systemd/logind.conf



Expected results:

No error and a successfully built, functioning server spin DVD image.


Additional info:

In the output in the middle of the dnf transaction:
Error in PREIN scriptlet in rpm package systemd

In the output at the end of the dnf transaction:
systemd-222-4.fc23.x86_64 was supposed to be installed but is not!

The files in the ./logs/ and ./work/Kickstart/x86_64/dnf/dnf.logs/ directories do not contain any details about the above errors.

The "--nomacboot" option to pungi is included only because I am running a custom built kernel which does not include the Apple related kernel modules.  However, the same problem occurs running the stock 4.2.0-300.fc23.x86_64 kernel from the Fedora repository binary RPM without the "--nomacboot" option.
Comment 1 Brian Lane 2015-09-24 14:20:52 EDT
This isn't a lorax problem, it is a problem with the repo, or with dnf picking the wrong set of packages. It blows up here because dnf didn't install systemd so the file doesn't exist.

systemd-222-4.fc23.x86_64 was supposed to be installed but is not!

See also bug 1262953
Comment 2 Michael Mráka 2015-09-25 05:41:33 EDT
There was a bug in dnf-1.1.2-2 which broke installs/updates.
Please try dnf-1.1.2-3
http://koji.fedoraproject.org/koji/buildinfo?buildID=687660.
Thanks.
Comment 3 Honza Silhan 2015-10-02 05:59:24 EDT

*** This bug has been marked as a duplicate of bug 1262953 ***

Note You need to log in before you can comment on or make changes to this bug.