Bug 1266387 - switch the default db driver to pymysql
switch the default db driver to pymysql
Status: CLOSED DUPLICATE of bug 1266032
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 03:28 EDT by Moshe Levi
Modified: 2016-04-18 02:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 04:20:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moshe Levi 2015-09-25 03:28:25 EDT
Description of problem:
In openstack Liberty QoS feature was introduce to neutron.
It doesn't work with MySQL-python-1.2.3
as Ihar Hrachyshka <ihrachys@redhat.com> said all the upstream project of 
openstack tested against pymysql so packstack should use it as the default db driver


Version-Release number of selected component (if applicable):

How reproducible:
1. install openstack with packstack on centos7
2. configure neutron QoS with openstack
3. neutron qos-policy-create test 
4. neutron qos-policy-show test


Actual results:
Error in neutron server
manual that corresponds to your MariaDB server version for the right syntax to use near ')' at line 3") 'SELECT qos_policies.tenant_id AS qos_policies_tenant_id, qos_policies.id AS qos_policies_id, qos_policies.name AS qos_policies_name, qos_policies.description AS qos_policies_description, qos_policies.shared AS qos_policies_shared \nFROM qos_policies \nWHERE qos_policies.name = %s' ([u'test'],)


Additional info:
Comment 2 Ihar Hrachyshka 2015-09-25 04:20:29 EDT

*** This bug has been marked as a duplicate of bug 1266032 ***

Note You need to log in before you can comment on or make changes to this bug.