Bug 1266460 - hammer puppet-module list fails with "Request Timeout"
hammer puppet-module list fails with "Request Timeout"
Status: CLOSED DUPLICATE of bug 1231579
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 06:46 EDT by Sebastian Hetze
Modified: 2015-11-05 02:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 07:09:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Hetze 2015-09-25 06:46:05 EDT
Description of problem:

hammer puppet-module list fails with "Request Timeout"

How reproducible:

This is depending on the number of puppet modules managed by Satellite and probably on the performance of the hardware involved.

Steps to Reproduce:
1. Create Product and Puppet Repo
2. Use http://forge.puppetlabs.com/ as URL
3. Sync this Repo
4. Try 'hammer puppet-module list'

Actual results:

Request Timeout

Expected results:

-------------------------------------|------------------------|------------------|---------
ID                                   | NAME                   | AUTHOR           | VERSION 
-------------------------------------|------------------------|------------------|---------
a56b50e4-b46d-4ffc-9ee6-84067386f52f | abiquo                 | abiquo           | 0.1.6   
32439576-0644-4156-8889-a18b83a0dc18 | abrt                   | CERNOps          | 0.2.3   
032accdc-805c-47e2-912c-6fedca788f41 | access_insights_client | lphiri           | 0.0.8
...

Additional info:

It of works you limit the number of output lines like:
'hammer puppet-module list --per-page 100'
'hammer puppet-module list --page 175'
Comment 1 Brad Buckingham 2015-10-16 07:09:14 EDT
The issue raised is due to the speed/performance of the query that retrieves the list of puppet modules.  This issue has been raised on the UI side as well and is being tracked with bug 1231579.  Since the cause is the same, I am going to close this one out as a duplicate; however, add a comment to that one to ensure CLI is also tested.  

Thanks for creating the bugzilla and if you have any questions or concerns, please re-open.

*** This bug has been marked as a duplicate of bug 1231579 ***

Note You need to log in before you can comment on or make changes to this bug.