Bug 1231579 - Adding Puppet Modules fails and freezes on the UI
Summary: Adding Puppet Modules fails and freezes on the UI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Repositories
Version: 6.1.0
Hardware: x86_64
OS: Linux
medium
high vote
Target Milestone: Unspecified
Assignee: David Davis
QA Contact: jcallaha
URL:
Whiteboard:
: 1199667 1266460 (view as bug list)
Depends On:
Blocks: sat61-release-notes
TreeView+ depends on / blocked
 
Reported: 2015-06-14 23:04 UTC by Michael Rustenbach
Modified: 2019-04-01 20:26 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:24:48 UTC


Attachments (Terms of Use)
Screenshot of bug result (235.20 KB, image/jpeg)
2015-06-14 23:04 UTC, Michael Rustenbach
no flags Details

Description Michael Rustenbach 2015-06-14 23:04:09 UTC
Created attachment 1038715 [details]
Screenshot of bug result

Description of problem:

When attempting to add new puppet module, the web browser freezes and displays the following error:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, open the script in the debugger, or let the script continue.

Script: https://sat01.domainname/assets/application-fddb49ee45f2655204f3b8dfa194d5fc.js:18

In addition, all the puppet module names show up as {{ item.module_name }}

Because of this, there is no way to add puppet modules to the content view.

Version-Release number of selected component (if applicable):

In /var/log/messages there is the following error:

puppet-agent[12852]: (/File[/var/lib/puppet/lib]) Could not evaluate: Could not retrieve information from environment production source(s) puppet://sat01.domainname/plugins

How reproducible:

Steps to Reproduce:
1.Content -> Content Views
2.Select Content View
3.Click on Puppet Modules
4.Click on Add Module

Actual results:
Browser freezes, module names are listed as {{ item.module_name }} and there is no way to add a module to the content view.

Expected results:
Modules to be listed by name and to be able to select version of module.

Additional info:
Running Red Hat Enterprise Linux 6.6 with the latest updates. See attached screenshot

Comment 1 Michael Rustenbach 2015-06-14 23:15:21 UTC
Tested with both Firefox ESR 38.0.1 and Google Chrome 43 (64-Bit) and same result.

Comment 2 RHEL Product and Program Management 2015-06-14 23:22:27 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Michael Rustenbach 2015-06-14 23:26:54 UTC
After waiting for about 20 minutes with Google Chrome, the modules did finally pull up by name. So it looks like it involves just taking a very long time for the modules to load. On a page refresh, I have to wait again for the 10-20 minute time for the modules to come up again.

Comment 5 Brad Buckingham 2015-10-16 11:09:14 UTC
*** Bug 1266460 has been marked as a duplicate of this bug. ***

Comment 6 Brad Buckingham 2015-10-16 11:10:38 UTC
Note: when testing the resolution for this bug, please ensure that the CLI is also able to list the puppet modules.  Refer to bug 1266460, which raises the issue of possible request timeouts.

Comment 8 David Davis 2016-03-07 16:16:59 UTC
*** Bug 1199667 has been marked as a duplicate of this bug. ***

Comment 9 David Davis 2016-03-10 20:53:35 UTC
This seems to work for me. I think infinite scroll was added when the page was converted to bastion 1.x.

Comment 10 jcallaha 2016-03-24 20:35:59 UTC
Verified in Satellite 6.2 Beta Snap 5.1

Comment 11 Bryan Kearney 2016-07-27 11:24:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.