Bug 126647 - htt_server -d infinite loop
htt_server -d infinite loop
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
: 131514 (view as bug list)
Depends On:
Blocks: FC3Target IIIMF
  Show dependency treegraph
 
Reported: 2004-06-24 02:34 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 11.4-69.svn1833
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 05:35:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-06-24 02:34:40 EDT
Description of problem:
If /etc/hosts is missing "localhost", htt_server -d fails with the
following message.

Fail to getaddrinfo:localhost, 9010
Failed to create any sockets for localhost:9010 ... exit.

When started with "service IIim start", this then causes 100% CPU
usage as the htt process loops with the following.

clone(child_stack=0,
flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD,
child_tidptr=0xf70138c8) = 26430
waitpid(26430, [{WIFEXITED(s) && WEXITSTATUS(s) == 255}], 0) = 26430
--- SIGCHLD (Child exited) @ 0 (0) ---

This flaw is minor as it was only exposed by misconfiguration caused
by another system-config-* tool, however im-sdk in the long run should
be more robust than this.  FC3 Target.
Comment 1 Akira TAGOH 2004-08-10 02:29:31 EDT
should be fixed in 11.4-69.svn1833. the changes is:
 - provides the useful information on syslog why htt_server died
 - don't try to run htt_server unlimitedly, try 5 times by default.
Comment 2 Akira TAGOH 2004-08-25 05:35:05 EDT
close this then.
Comment 3 Akira TAGOH 2004-09-02 04:37:00 EDT
*** Bug 131514 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.