Bug 131514 - /usr/sbin/htt forking dozens of times a second
/usr/sbin/htt forking dozens of times a second
Status: CLOSED DUPLICATE of bug 126647
Product: Fedora
Classification: Fedora
Component: im-sdk (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Yu Shao
: i18n
Depends On:
Blocks: IIIMF
  Show dependency treegraph
 
Reported: 2004-09-01 16:18 EDT by Dave Malcolm
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2004-09-01 16:18:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
My CPU load was at 100%, but nothing significant was appearing in
"top".  Investigating further by typing "ps" twice in rapid sucesssion
reveals that about 100-150 PIDs were being used a second.

I managed to spot transitory threads of /usr/sbin/htt in a "ps ax" and
tried killing the parent /usr/bin/htt.  As soon as I did this my CPU
load went down to near zero, and the rapid increase of PID numbers has
stopped.

So I believe that /usr/sbin/htt was rapidly forking then killing new
threads (which brought my system to its knees, CPU-wise)

Version-Release number of selected component (if applicable):
iiimf-server-11.4-41

How reproducible:
Didn't try

Steps to Reproduce:
1. install the iimf-server package
2. 
3.
    

Actual Results:  CPU load at 100% with no apparent cause

Expected Results:  This package shouldn't take up 100% CPU time, or
fork hundred of times a second.

Additional info:
Comment 1 Lawrence Lim 2004-09-01 23:05:22 EDT
Hi Dave,
This bug sounds very similar to bug 126647. Would you like to try the
latest rawhide 12.0.1.-1 (major release)? Please let me know if
problem still presists for you.


Thanks,
Lawrence
Comment 2 Akira TAGOH 2004-09-02 04:36:58 EDT
Since this bug is for the development of FC and installed iiimf-server
is too old, this bug should be marked as DUPLICATED then. if you could
still reproduce this problem on even the latest package, please reopen
a bug.

*** This bug has been marked as a duplicate of 126647 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:05:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.