Bug 126652 - init fails to load firmware for prism54 card
init fails to load firmware for prism54 card
Status: CLOSED DUPLICATE of bug 112824
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 07:20 EDT by John Brookes
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Brookes 2004-06-24 07:20:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
During boot, when network is being started, I get the message:

 SIOCSIFFLAGS: No such file or directory

and the interface fails to come up.

When booted, doing ifup on the interface succeeds without problem

The device is:

02:04.0 Network controller: Intersil Corporation Intersil ISL3890
[Prism GT/Prism Duette] (rev 01)

Version-Release number of selected component (if applicable):
7.53-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC2
2. Boot it

    

Actual Results:  The interface does not come up, giving the error in
the description, indicating that the firmware could not be loaded.

/var/log/messages contains:
Jun 24 11:44:17 localhost kernel: eth0: could not upload firmware
('isl3890')
Jun 24 11:44:17 localhost kernel: prism54: request_firmware() failed
for 'isl3890'


Expected Results:  Firmware should load, interface should come up.

Additional info:
Comment 1 Bill Nottingham 2004-06-29 01:06:23 EDT

*** This bug has been marked as a duplicate of 112824 ***
Comment 2 Jeff Gold 2004-10-02 15:16:47 EDT
Please change this bug so that it is no longer a duplicate of bug
112824.  These are *not* the same problem, and this issue is *not*
resolved by the fix for bug 112824.

I have an x86_64 system with a PCI prism54 device running FC2 on which
I have installed initscripts-7.80-1 and mkinitrd-4.1.11-1 from FC3
test2 and the behavior is unchanged.  Specifically, the network card
cannot start at boot because without hotplug support firmware cannot
be loaded.  Using ifup later brings it up with no problems and can be
used as a work around.

Still, this should be fixed because in many cases it is quite
cumbersome.  For example, I run DNS and DHCP (the machine is
essentially an 802.11g access point) so these services must be
restarted as well.
Comment 3 Bill Nottingham 2004-10-03 23:13:28 EDT
Did you *only* install the initscripts and mkinitrd from FC3 test?
Comment 4 Red Hat Bugzilla 2006-02-21 14:04:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.