This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1266637 - [abrt] xorg-x11-server-Xwayland: gl_provider_resolver(): Xwayland killed by SIGABRT
[abrt] xorg-x11-server-Xwayland: gl_provider_resolver(): Xwayland killed by S...
Status: CLOSED DUPLICATE of bug 1265997
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6af65806f9d3fc217f70ba21fba...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 20:06 EDT by Kevin Fenzi
Modified: 2015-09-28 14:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 14:52:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.29 KB, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: cgroup (199 bytes, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: core_backtrace (8.75 KB, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: dso_list (6.33 KB, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: environ (1012 bytes, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-25 20:06 EDT, Kevin Fenzi
no flags Details
File: maps (31.04 KB, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details
File: mountinfo (3.45 KB, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details
File: open_fds (517 bytes, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details
File: proc_pid_status (1013 bytes, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details
File: var_log_messages (504 bytes, text/plain)
2015-09-25 20:07 EDT, Kevin Fenzi
no flags Details

  None (edit)
Description Kevin Fenzi 2015-09-25 20:06:48 EDT
Description of problem:
Just starting up, gdm comes up and crashes.

Version-Release number of selected component:
xorg-x11-server-Xwayland-1.18.0-0.2.20150907.fc24

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/Xwayland :1024 -rootless -noreset -listen 4 -listen 5 -displayfd 6
crash_function: gl_provider_resolver
executable:     /usr/bin/Xwayland
global_pid:     2021
kernel:         4.3.0-0.rc2.git0.1.fc24.x86_64
runlevel:       unknown
type:           CCpp
uid:            42

Truncated backtrace:
Thread no. 1 (9 frames)
 #2 gl_provider_resolver at gl_generated_dispatch.c:8395
 #3 gl_single_resolver at gl_generated_dispatch.c:8408
 #4 epoxy_glEGLImageTargetTexture2DOES_resolver at gl_generated_dispatch.c:15881
 #5 epoxy_glEGLImageTargetTexture2DOES_global_rewrite_ptr at gl_generated_dispatch.c:45543
 #6 xwl_glamor_create_pixmap_for_bo at xwayland-glamor.c:143
 #7 ProcCreatePixmap at dispatch.c:1405
 #8 Dispatch at dispatch.c:415
 #9 dix_main at main.c:277
 #11 _start
Comment 1 Kevin Fenzi 2015-09-25 20:06:51 EDT
Created attachment 1077286 [details]
File: backtrace
Comment 2 Kevin Fenzi 2015-09-25 20:06:52 EDT
Created attachment 1077287 [details]
File: cgroup
Comment 3 Kevin Fenzi 2015-09-25 20:06:53 EDT
Created attachment 1077288 [details]
File: core_backtrace
Comment 4 Kevin Fenzi 2015-09-25 20:06:54 EDT
Created attachment 1077289 [details]
File: dso_list
Comment 5 Kevin Fenzi 2015-09-25 20:06:55 EDT
Created attachment 1077290 [details]
File: environ
Comment 6 Kevin Fenzi 2015-09-25 20:06:56 EDT
Created attachment 1077291 [details]
File: limits
Comment 7 Kevin Fenzi 2015-09-25 20:07:00 EDT
Created attachment 1077292 [details]
File: maps
Comment 8 Kevin Fenzi 2015-09-25 20:07:05 EDT
Created attachment 1077293 [details]
File: mountinfo
Comment 9 Kevin Fenzi 2015-09-25 20:07:06 EDT
Created attachment 1077294 [details]
File: namespaces
Comment 10 Kevin Fenzi 2015-09-25 20:07:07 EDT
Created attachment 1077295 [details]
File: open_fds
Comment 11 Kevin Fenzi 2015-09-25 20:07:08 EDT
Created attachment 1077296 [details]
File: proc_pid_status
Comment 12 Kevin Fenzi 2015-09-25 20:07:09 EDT
Created attachment 1077297 [details]
File: var_log_messages
Comment 13 Adel Gadllah 2015-09-28 14:52:38 EDT

*** This bug has been marked as a duplicate of bug 1265997 ***

Note You need to log in before you can comment on or make changes to this bug.