Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1266773 - dnf says "nothing to do" when apper (correctly) reports "you have 157 new updates"
Summary: dnf says "nothing to do" when apper (correctly) reports "you have 157 new upd...
Keywords:
Status: CLOSED DUPLICATE of bug 1265336
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 23
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-27 16:39 UTC by Jeremy Uchitel
Modified: 2015-09-29 08:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-29 08:13:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Jeremy Uchitel 2015-09-27 16:39:45 UTC
Description of problem:
Apper reminds me (hourly!) that I have 157 new updates available.  dnf refuses to present them unless given explicit package names or matching wildcards.




Version-Release number of selected component (if applicable):


How reproducible:

1) "dnf clean metadata"
2) "dnf --refresh upgrade"
3) backing up /var/cache/dnf, wiping it out and running the above
4) setting  the updates-testing repo to a single repository and repeating above.

All give "nothing to do" message.

*IF*, however, I give dnf a specific package or wildcard match, in back-to-back runs and repeated samples, dnf magically finds it has updates.  For example, running:

dnf upgrade 'kf5*' will show a list that matches apper's list of kf5* packages.  However running dnf upgrade immediately after gives me the dreaded "nothing to do" message.

Actual results:
dnf gives "nothing to do" message when not provided a package name.

Expected results:
dnf upgrade should upgrade these packages without specifying names or wildcards.

Additional info:

Comment 1 Jeremy Uchitel 2015-09-27 16:41:34 UTC
Just to cover all the bases, the single repo I picked, Georgia Tech's www.gtlib.gatech.edu DOES have the updated packages listed.

Comment 2 Michael Mráka 2015-09-29 08:13:00 UTC

*** This bug has been marked as a duplicate of bug 1265336 ***


Note You need to log in before you can comment on or make changes to this bug.