Bug 1266776 - machinectl fails to start f23 beta image: Failed to open /dev/loop-control
machinectl fails to start f23 beta image: Failed to open /dev/loop-control
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
: 1288104 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 13:39 EDT by François Kooman
Modified: 2015-12-17 02:24 EST (History)
8 users (show)

See Also:
Fixed In Version: systemd-222-10.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 02:24:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description François Kooman 2015-09-27 13:39:46 EDT
Description of problem:

machinectl fails to start f23 beta image: Failed to open /dev/loop-control

Version-Release number of selected component (if applicable):

[root@f23beta ~]# rpm -qf `which machinectl`
systemd-222-6.fc23.x86_64
[root@f23beta ~]# 

How reproducible:

always

Steps to Reproduce:

downloaded the f23 beta cloud image and saved it as f23.raw.xz, because of https://bugzilla.redhat.com/show_bug.cgi?id=1266775

[root@f23beta ~]# machinectl list-images
NAME TYPE RO  USAGE CREATED MODIFIED

0 images listed.
[root@f23beta ~]# machinectl import-raw /home/fedora/f23.raw.xz
Enqueued transfer job 1. Press C-c to continue download in background.
Importing '/home/fedora/f23.raw.xz', saving as 'f23'.
Imported 0%.
Imported 1%.
...
Imported 99%.
Imported 100%.
Operation completed successfully.
Exiting.
[root@f23beta ~]# machinectl list-images
NAME TYPE RO  USAGE  CREATED MODIFIED                   
f23  raw  no  647.1M n/a     Sun 2015-09-27 13:50:36 UTC

1 images listed.
[root@f23beta ~]# machinectl start f23
Job for systemd-nspawn@f23.service failed because the control process exited with error code. See "systemctl status systemd-nspawn@f23.service" and "journalctl -xe" for details.

Actual results:

Sep 27 17:35:08 f23beta.localdomain systemd[1]: Starting Container f23...
Sep 27 17:35:08 f23beta.localdomain systemd-nspawn[854]: Failed to open /dev/loop-control: Operation not permitted
Sep 27 17:35:08 f23beta.localdomain systemd[1]: systemd-nspawn@f23.service: Main process exited, code=exited, status=1/FAILURE
Sep 27 17:35:08 f23beta.localdomain systemd[1]: Failed to start Container f23.
Sep 27 17:35:08 f23beta.localdomain systemd[1]: systemd-nspawn@f23.service: Unit entered failed state.
Sep 27 17:35:08 f23beta.localdomain systemd[1]: systemd-nspawn@f23.service: Failed with result 'exit-code'.


Expected results:

container should start

Additional info:

I set selinux to permissive, but that didn't help.
Comment 1 Jan Synacek 2015-10-02 08:00:06 EDT
Filed upstream as https://github.com/systemd/systemd/issues/1446.
Comment 3 Neil Wilson 2015-12-03 10:17:37 EST
*** Bug 1288104 has been marked as a duplicate of this bug. ***
Comment 4 Neil Wilson 2015-12-03 10:18:48 EST
Still an issue on release of F23.
Comment 5 Fedora Update System 2015-12-14 06:17:47 EST
systemd-222-9.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-76fc543765
Comment 6 Fedora Update System 2015-12-14 07:29:08 EST
systemd-222-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-76fc543765
Comment 7 Fedora Update System 2015-12-15 05:54:05 EST
systemd-222-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update systemd'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-76fc543765
Comment 8 Fedora Update System 2015-12-17 02:23:20 EST
systemd-222-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.