Bug 1266785 - Cannot start catfish on F-23
Summary: Cannot start catfish on F-23
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: catfish
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1267480 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-27 21:44 UTC by Mukundan Ragavan
Modified: 2015-10-05 06:52 UTC (History)
4 users (show)

Fixed In Version: catfish-1.3.2-2.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-04 19:14:50 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
strace output (19.83 KB, text/plain)
2015-09-28 21:33 UTC, Mukundan Ragavan
no flags Details
list of installed packages (298.68 KB, text/plain)
2015-09-29 00:59 UTC, Mukundan Ragavan
no flags Details

Description Mukundan Ragavan 2015-09-27 21:44:41 UTC
When I try to open catfish, I see nothing. 

So,I tried opening it from the terminal and got this - 

mukundan @ imladris ~$ catfish 
/usr/share/catfish/catfish/__init__.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk  # pylint: disable=E0611
/usr/bin/locate

(catfish.py:3508): Gtk-WARNING **: gtkwidget.c:8463: widget not within a GtkWindow
Traceback (most recent call last):
  File "/usr/share/catfish/bin/catfish.py", line 44, in <module>
    catfish.main()
  File "/usr/share/catfish/catfish/__init__.py", line 73, in main
    window = CatfishWindow.CatfishWindow()
  File "/usr/share/catfish/catfish_lib/Window.py", line 170, in __new__
    new_object.finish_initializing(builder)
  File "/usr/share/catfish/catfish/CatfishWindow.py", line 258, in finish_initializing
    menuitem.hide()
AttributeError: 'NoneType' object has no attribute 'hide'


$ rpm -qa catfish
catfish-1.3.2-1.fc23.noarch

Comment 1 Mamoru TASAKA 2015-09-28 04:13:06 UTC
I cannot reproduce this.
* First of all, would you attach the result of
  $ rpm -qa | sort
?

* Also, would you attach the result of
  $ strace -s 1000 catfish
?

Comment 2 Mamoru TASAKA 2015-09-28 08:56:04 UTC
Can you reproduce this even if you create new user and login to the new user?

Comment 3 Mukundan Ragavan 2015-09-28 21:33:15 UTC
Created attachment 1078075 [details]
strace output

Comment 4 Mukundan Ragavan 2015-09-28 21:33:55 UTC
I got the crash when I opened catfish for the first time ever .. So, it was a new user.

Comment 5 Mamoru TASAKA 2015-09-28 22:27:34 UTC
(In reply to Mukundan Ragavan from comment #4)
> I got the crash when I opened catfish for the first time ever .. So, it was
> a new user.

Well, that does not mean it is a new user. Would you try creating a new user now and test this is still reproducible on the new user?

Also, would you attach the result of $ rpm -qa | sort ?

Comment 6 Mukundan Ragavan 2015-09-29 00:59:56 UTC
Created attachment 1078089 [details]
list of installed packages

Yes. I can reproduce this on a new user *AND* on another system.

list od packages attached.

$ cat all-pkgs.out | wc -l
6870

Comment 7 Mamoru TASAKA 2015-09-30 10:10:08 UTC
Oh, maybe if you add yourself to sudoers, this error disappears?

Comment 9 Mamoru TASAKA 2015-10-01 01:30:45 UTC
*** Bug 1267480 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2015-10-01 03:42:50 UTC
catfish-1.3.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-66b4e8da17

Comment 11 Mukundan Ragavan 2015-10-01 22:02:09 UTC
Yup! This works!

Thanks for the quick fix.

Comment 12 Fedora Update System 2015-10-04 01:53:37 UTC
catfish-1.3.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update catfish'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-66b4e8da17

Comment 13 Fedora Update System 2015-10-04 19:14:48 UTC
catfish-1.3.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Mamoru TASAKA 2015-10-05 06:52:58 UTC
Thank you for testing. Now the fixed package is pushed.


Note You need to log in before you can comment on or make changes to this bug.