Bug 1267480 - [abrt] catfish: CatfishWindow.py:258:finish_initializing:AttributeError: 'NoneType' object has no attribute 'hide'
[abrt] catfish: CatfishWindow.py:258:finish_initializing:AttributeError: 'Non...
Status: CLOSED DUPLICATE of bug 1266785
Product: Fedora
Classification: Fedora
Component: catfish (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:33df72c861fd83138615fe95654...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 03:22 EDT by Farid
Modified: 2015-10-02 04:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 21:30:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.28 KB, text/plain)
2015-09-30 03:22 EDT, Farid
no flags Details
File: environ (1.89 KB, text/plain)
2015-09-30 03:22 EDT, Farid
no flags Details

  None (edit)
Description Farid 2015-09-30 03:22:33 EDT
Version-Release number of selected component:
catfish-1.3.2-1.fc23

Additional info:
reporter:       libreport-2.6.2
cmdline:        python2 /usr/share/catfish/bin/catfish.py
executable:     /usr/share/catfish/bin/catfish.py
kernel:         4.2.1-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
CatfishWindow.py:258:finish_initializing:AttributeError: 'NoneType' object has no attribute 'hide'

Traceback (most recent call last):
  File "/usr/share/catfish/bin/catfish.py", line 44, in <module>
    catfish.main()
  File "/usr/share/catfish/catfish/__init__.py", line 73, in main
    window = CatfishWindow.CatfishWindow()
  File "/usr/share/catfish/catfish_lib/Window.py", line 170, in __new__
    new_object.finish_initializing(builder)
  File "/usr/share/catfish/catfish/CatfishWindow.py", line 258, in finish_initializing
    menuitem.hide()
AttributeError: 'NoneType' object has no attribute 'hide'

Local variables in innermost frame:
box: <Box object at 0x7f6881434050 (GtkBox at 0x560211668f80)>
completion: <EntryCompletion object at 0x7f688143ad70 (GtkEntryCompletion at 0x560211561b80)>
parent: <Box object at 0x7f68800c7690 (GtkBox at 0x560211405e30)>
overlay: <Overlay object at 0x7f688143ae10 (GtkOverlay at 0x56021164c500)>
builder: <Builder object at 0x7f688826b410 (catfish_lib+Builder+Builder at 0x5602110df2f0)>
listmodel: <ListStore object at 0x7f688143ad20 (GtkListStore at 0x5602116b6780)>
scrolledwindow: <ScrolledWindow object at 0x7f68800c7960 (GtkScrolledWindow at 0x560211322820)>
menuitem: None
self: <CatfishWindow object at 0x7f688826b3c0 (CatfishWindow at 0x560211328720)>
Comment 1 Farid 2015-09-30 03:22:37 EDT
Created attachment 1078548 [details]
File: backtrace
Comment 2 Farid 2015-09-30 03:22:39 EDT
Created attachment 1078549 [details]
File: environ
Comment 3 Mamoru TASAKA 2015-09-30 21:30:45 EDT

*** This bug has been marked as a duplicate of bug 1266785 ***

Note You need to log in before you can comment on or make changes to this bug.