Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1266793 - /static/dashboard/img/loading.gif not found
Summary: /static/dashboard/img/loading.gif not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: z3
: 7.0 (Kilo)
Assignee: Matthias Runge
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-28 00:03 UTC by Marius Cornea
Modified: 2015-12-21 17:05 UTC (History)
5 users (show)

Fixed In Version: python-django-horizon-2015.1.2-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1297388 (view as bug list)
Environment:
Last Closed: 2015-12-21 17:05:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1505976 0 None None None Never
OpenStack gerrit 243026 0 None None None Never
Red Hat Product Errata RHBA-2015:2675 0 normal SHIPPED_LIVE python-django-horizon bug fix advisory 2015-12-21 21:51:29 UTC

Description Marius Cornea 2015-09-28 00:03:38 UTC
Description of problem:
loading.gif appears to be loading from wrong URL.

Version-Release number of selected component (if applicable):
openstack-dashboard-2015.1.1-2.el7ost.noarch
python-django-horizon-2015.1.1-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Go to Object store
2. Create container
3. You'll see a broken image for a couple of seconds, until the container is created. You can see the 404 in the browser console. 

Actual results:
http://172.16.23.10/static/dashboard/img/loading.gif 404 (Not Found)

Expected results:
loading.gif is loaded.

Additional info:
The image can be found at http://172.16.23.10/dashboard/static/dashboard/img/loading.gif

Setup has been deployed with OSP-d with 3 controllers.

Comment 2 Matthias Runge 2015-11-10 08:22:47 UTC
Corresponding patch: https://review.openstack.org/#/c/243026/

The patch is low risk, but adds the indicator, that something is being loaded
in the background back to containers panel.

Comment 6 Ido Ovadia 2015-12-01 13:57:15 UTC
Verified
========
python-django-horizon-2015.1.2-3.el7ost.noarch

Comment 8 errata-xmlrpc 2015-12-21 17:05:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2675


Note You need to log in before you can comment on or make changes to this bug.