Bug 1297388 - /static/dashboard/img/loading.gif not found
/static/dashboard/img/loading.gif not found
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity low
: ga
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-11 06:52 EST by Marius Cornea
Modified: 2016-04-07 17:21 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.0-9.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1266793
Environment:
Last Closed: 2016-04-07 17:21:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2016-01-11 06:52:01 EST
Version-Release number of selected component:
python-django-horizon-8.0.0-8.el7ost.noarch

+++ This bug was initially created as a clone of Bug #1266793 +++

Description of problem:
loading.gif appears to be loading from wrong URL.

Version-Release number of selected component (if applicable):
openstack-dashboard-2015.1.1-2.el7ost.noarch
python-django-horizon-2015.1.1-2.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Go to Object store
2. Create container
3. You'll see a broken image for a couple of seconds, until the container is created. You can see the 404 in the browser console. 

Actual results:
http://172.16.23.10/static/dashboard/img/loading.gif 404 (Not Found)

Expected results:
loading.gif is loaded.

Additional info:
The image can be found at http://172.16.23.10/dashboard/static/dashboard/img/loading.gif

Setup has been deployed with OSP-d with 3 controllers.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-09-27 20:03:43 EDT ---

Since this issue was entered in bugzilla without a release flag set, rhos-8.0? has been automatically added to ensure that it is properly evaluated for this release.

--- Additional comment from Matthias Runge on 2015-11-10 03:22:47 EST ---

Corresponding patch: https://review.openstack.org/#/c/243026/

The patch is low risk, but adds the indicator, that something is being loaded
in the background back to containers panel.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-10 03:22:51 EST ---

This bug has been given a pm_ack+ since it is not a blocker, has been triaged, and does not need pm review.

--- Additional comment from Matthias Runge on 2015-11-10 08:04:18 EST ---

https://code.engineering.redhat.com/gerrit/#/c/61179/

--- Additional comment from errata-xmlrpc on 2015-11-13 15:37:03 EST ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2015:21936-01
https://errata.devel.redhat.com/advisory/21936

--- Additional comment from Ido Ovadia on 2015-12-01 08:57:15 EST ---

Verified
========
python-django-horizon-2015.1.2-3.el7ost.noarch

--- Additional comment from errata-xmlrpc on 2015-12-20 04:09:38 EST ---

Bug report changed to RELEASE_PENDING status by Errata System.
Advisory RHBA-2015:21936-07 has been changed to PUSH_READY status.
https://errata.devel.redhat.com/advisory/21936

--- Additional comment from errata-xmlrpc on 2015-12-21 12:05:04 EST ---

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2675
Comment 3 Amit Ugol 2016-01-25 10:29:50 EST
# locate loading.gif
/usr/share/openstack-dashboard/openstack_dashboard/static/dashboard/img/loading.gif
/usr/share/openstack-dashboard/static/dashboard/img/loading.gif

Looks OK in the page
Comment 4 errata-xmlrpc 2016-04-07 17:21:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.