Bug 1266818 - Disabling enable-shared-storage deletes the volume with the name - "gluster_shared_storage"
Disabling enable-shared-storage deletes the volume with the name - "gluster_s...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Satish Mohan
: ZStream
Depends On: 1236503
Blocks: 1216951 1317425
  Show dependency treegraph
 
Reported: 2015-09-28 01:47 EDT by Gaurav Kumar Garg
Modified: 2016-06-16 09:38 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1236503
: 1317425 (view as bug list)
Environment:
RHEL 6.7
Last Closed: 2016-06-16 09:38:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Nekkunti 2015-10-05 01:47:13 EDT
patch: http://review.gluster.org/#/c/12232/
Comment 2 Vijay Bellur 2015-10-12 08:38:25 EDT
REVIEW: http://review.gluster.org/12232 (glusterd: disabling enable-shared-storage option should not delete volume) posted (#6) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-10-13 10:07:09 EDT
REVIEW: http://review.gluster.org/12232 (glusterd: disabling enable-shared-storage option should not delete volume) posted (#7) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-10-13 23:45:22 EDT
COMMIT: http://review.gluster.org/12232 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit f88d0ade1c09aa1a3cee3713dc851da9552d7ff5
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Thu Sep 24 18:04:23 2015 +0530

    glusterd: disabling enable-shared-storage option should not delete volume
    
    Previously when you create volume with "glusterd_shared_storage" name
    and if user disable enable-shared-storage option then gluster will
    delete the "glusterd_shared_storage" volume.
    
    With this fix gluster will do appropriate validation of
    enable-shared-storage option and it will not delete volume with
    "glusterd_shared_storage" name if it is a user created volume.
    
    Change-Id: I2bd92f938fb3de6ef496a934933bdcea9f251491
    BUG: 1266818
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12232
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 7 Niels de Vos 2016-06-16 09:38:14 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.