Bug 1317425 - Disabling enable-shared-storage deletes the volume with the name - "gluster_shared_storage"
Summary: Disabling enable-shared-storage deletes the volume with the name - "gluster_s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.7.0
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Gaurav Kumar Garg
QA Contact:
URL:
Whiteboard:
Depends On: 1266818
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-14 08:51 UTC by Gaurav Kumar Garg
Modified: 2016-04-19 06:59 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.7.10
Doc Type: Bug Fix
Doc Text:
Clone Of: 1266818
Environment:
RHEL 6.7
Last Closed: 2016-04-19 06:59:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-03-14 09:15:30 UTC
REVIEW: http://review.gluster.org/13695 (glusterd: disabling enable-shared-storage option should not delete volume) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)

Comment 2 Vijay Bellur 2016-03-21 17:55:55 UTC
COMMIT: http://review.gluster.org/13695 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 9b3a1d1c51df28e3a0301082819c78fae0e8fb68
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Mon Mar 14 14:36:11 2016 +0530

    glusterd: disabling enable-shared-storage option should not delete volume
    
    This patch is a backport of: http://review.gluster.org/#/c/12232/
    
    Previously, when you create volume with "glusterd_shared_storage" name
    and if user disable, enable-shared-storage option then gluster will
    delete the "glusterd_shared_storage" volume.
    
    With this fix gluster will do appropriate validation of
    enable-shared-storage option and it will not delete volume with
    "glusterd_shared_storage" name if it is a user created volume.
    
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
      >> Change-Id: I2bd92f938fb3de6ef496a934933bdcea9f251491
      >> BUG: 1266818
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
      >> Reviewed-on: http://review.gluster.org/12232
      >> Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
      >> Reviewed-by: Anand Nekkunti <anekkunt@redhat.com>
      >> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
      >> Tested-by: Gluster Build System <jenkins@build.gluster.com>
    
    Change-Id: I8cb160fece702a730e25dadbc740e74efc57483e
    BUG: 1317425
    Reviewed-on: http://review.gluster.org/13695
    Tested-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Kaushal 2016-04-19 06:59:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.10, please open a new bug report.

glusterfs-3.7.10 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-April/026164.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.