Bug 1266827 - [RFE] add confirmation step for manifest deletion (explaining when refresh will do, and when have to use delete)
Summary: [RFE] add confirmation step for manifest deletion (explaining when refresh wi...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Bruno Rocha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Keywords: FutureFeature, PrioBumpGSS, PrioBumpPM, Triaged, UserExperience
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker CEE_Sat6_Top_BZs, GSS_Sat6_Top_Bugs
TreeView+ depends on / blocked
 
Reported: 2015-09-28 06:43 UTC by Xixi
Modified: 2019-06-13 21:25 UTC (History)
13 users (show)

(edit)
Clone Of:
: 1446707 (view as bug list)
(edit)
Last Closed: 2017-06-20 17:53:46 UTC


Attachments (Terms of Use)
no message in dialog screenshot (5.79 KB, image/png)
2017-05-26 14:42 UTC, Evgeni Golov
no flags Details
Verified: popup dialog is working (105.29 KB, image/png)
2017-06-06 19:44 UTC, Bruno Rocha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 18696 None None None 2017-02-27 16:03 UTC
Red Hat Bugzilla 1292229 None None None 2019-05-10 07:50 UTC
Red Hat Bugzilla 1292242 None CLOSED [RFE] Add explanation about what manifest refresh and delete do 2019-05-10 07:50 UTC

Internal Trackers: 1292229 1292242

Description Xixi 2015-09-28 06:43:56 UTC
Description of problem:
It's reported that oftentimes customers delete manifest when trying to update subscriptions / upload a newer manifest, in which case all that's needed is a Refresh, and deletion would cause problems by losing/disconfiguring server and client subscriptions etc.  The only times where manifest needs to be deleted includes when a Satellite server is no longer active or the manifest has been removed from the Customer Portal.  

A confirmation step will address this confusion by explaining to users refresh vs delete and asking if they're sure they want to delete manifest or just go back and refresh it.

Version-Release number of selected component (if applicable):
Satellite 6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Xixi 2016-02-24 23:47:11 UTC
possible duplicate:
Bug 1292242 - [RFE] Add explanation about what manifest refresh and delete do

Comment 3 Bryan Kearney 2016-07-08 20:39:29 UTC
Per 6.3 planning, moving out non acked bugs to the backlog

Comment 8 Rich Jerrido 2017-02-14 21:25:37 UTC
Deleting a subscription manifest is one of the most destructive operations that can be done in a Satellite organization. I am STRONGLY in support of giving the user a very stern warning requiring an additional confirmation before deleting a manifest. 

Manifest deletion means that 

- I have to reupload my manifest. 
- I have to reattach subs to 
  - systems
  - hypervisors
  - activation keys. 

And while attaching subs is significantly better in Satellite 6.2.2+ this situation is best avoided. It is exceedingly rare to actually in a production scenario to have to DELETE a manifest.

Comment 11 Chris Roberts 2017-02-27 15:32:48 UTC
Created redmine issue for this sprint:

http://projects.theforeman.org/issues/18696

Comment 13 Bryan Kearney 2017-03-02 20:39:55 UTC
Chris, can you please bump this to the top of your queue. We are getting feedback it would be a big win for CEE.

Comment 14 pm-sat@redhat.com 2017-03-24 16:06:39 UTC
Upstream bug assigned to chrobert@redhat.com

Comment 16 pm-sat@redhat.com 2017-03-31 18:07:00 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/18696 has been resolved.

Comment 18 Evgeni Golov 2017-05-26 14:42 UTC
Created attachment 1282630 [details]
no message in dialog screenshot

seems the message is not properly displayed in the popup dialog, see screenshot

Comment 19 Bruno Rocha 2017-05-30 15:57:45 UTC
Confirmed in satellite-6.2.10-2.0.el7sat.noarch

as the attachment above, the dialog is displayed but missing the message.

Comment 28 Bruno Rocha 2017-06-06 19:44 UTC
Created attachment 1285583 [details]
Verified: popup dialog is working

verified in satellite-6.2.10-3.0.el7sat.noarch

Comment 29 Bruno Rocha 2017-06-06 19:45:08 UTC
I accidentally changed the assignee.. fixing it.

Comment 30 Bryan Kearney 2017-06-20 17:53:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1553


Note You need to log in before you can comment on or make changes to this bug.