Bug 1266861 - IP address 127.x.x.x is not removed from ethX interface during "ifdown ethX"
IP address 127.x.x.x is not removed from ethX interface during "ifdown ethX"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.7
All Linux
medium Severity medium
: rc
: 6.8
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: ZStream
Depends On:
Blocks: 1172231 1279935
  Show dependency treegraph
 
Reported: 2015-09-28 05:03 EDT by Petr Barta
Modified: 2016-11-25 07:58 EST (History)
6 users (show)

See Also:
Fixed In Version: initscripts-9.03.50-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279935 (view as bug list)
Environment:
Last Closed: 2016-05-10 21:07:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2038793 None None None Never

  None (edit)
Description Petr Barta 2015-09-28 05:03:01 EDT
Description of problem:

IP address of 127.x.x.x family is not removed from eth interface during ifdown eth

Version-Release number of selected component (if applicable):

initscripts-9.03.49-1.el6.x86_64

How reproducible:

Always

Steps to Reproduce:
1. configure /etc/sysconfig/network-scripts/ifcfg-eth0 with IPADDR=127.x.x.x (any IP from 127.0.0.0/8 will do)
2. ifup eth0
3. Check that the IP is present there:
# ip addr sh eth0
4. ifdown eth0


Actual results:

Address from step 1 is still present on the interface

Expected results:

Address from step 1 is removed from the interface after step 4

Additional info:

ifdown works properly with any (tested) IP ouside of 127.0.0.0/8
Comment 2 Lukáš Nykrýn 2015-10-14 09:43:37 EDT
Culprit is fix for bug https://bugzilla.redhat.com/show_bug.cgi?id=698781
Comment 8 Patrick Talbert 2015-12-18 10:52:49 EST
I think this fix may be causing a regression:

https://bugzilla.redhat.com/show_bug.cgi?id=1292875


I apologize if opening a new bug was not warranted.


Thank you,

Patrick
Comment 12 errata-xmlrpc 2016-05-10 21:07:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0951.html

Note You need to log in before you can comment on or make changes to this bug.