Bug 1292875 - ifdown on an alias interface removes all IP addresses
ifdown on an alias interface removes all IP addresses
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.7
All Linux
urgent Severity urgent
: rc
: 6.8
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
: Regression, ZStream
Depends On:
Blocks: 1172231 1300971
  Show dependency treegraph
 
Reported: 2015-12-18 10:43 EST by Patrick Talbert
Modified: 2016-05-10 21:07 EDT (History)
9 users (show)

See Also:
Fixed In Version: initscripts-9.03.50-1.el6
Doc Type: Bug Fix
Doc Text:
Previously, when an alias interface was brought down using the ifdown command, the LABEL variable was not set due to a typo in the ifdown-eth script. Consequently, instead of removing just addresses belonging to the alias interface, all IP addresses on the device were removed. This bug has been fixed, and the script now correctly removes only IP addresses of the alias interface in this scenario.
Story Points: ---
Clone Of:
: 1300971 (view as bug list)
Environment:
Last Closed: 2016-05-10 21:07:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2099351 None None None 2015-12-18 10:52 EST

  None (edit)
Description Patrick Talbert 2015-12-18 10:43:20 EST
Description of problem:
Running ifdown on an alias interface removes every IPv4 address from the interface.


Version-Release number of selected component (if applicable):
9.03.49-1.el6 to 9.03.49-1.el6_7.3


How reproducible:
Always.


Steps to Reproduce:
1. Create two aliases:

/etc/sysconfig/network-scripts/ifcfg-eth0
-------------------------------------------
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.122.101
NETMASK=255.255.255.0
GATEWAY=192.168.122.1
DNS1=192.168.122.1
DEFROUTE=yes

/etc/sysconfig/network-scripts/ifcfg-eth0:1
-------------------------------------------
DEVICE=eth0:1
BOOTPROTO=none
IPADDR=192.168.122.102
NETMASK=255.255.255.0
ONPARENT=no

/etc/sysconfig/network-scripts/ifcfg-eth0:2
-------------------------------------------
DEVICE=eth0:2
BOOTPROTO=none
IPADDR=192.168.122.103
NETMASK=255.255.255.0
ONPARENT=no



2. Bring them up with ifup:

# ip addr show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:54:00:d8:c5:ea brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.101/24 brd 192.168.122.255 scope global eth0
    inet 192.168.122.102/24 brd 192.168.122.255 scope global secondary eth0:1
    inet 192.168.122.103/24 brd 192.168.122.255 scope global secondary eth0:2
    inet6 fe80::5054:ff:fed8:c5ea/64 scope link 
       valid_lft forever preferred_lft forever



3. Bring one of them down with ifdown:

# ifdown eth0:1



Actual results:

All the IPv4 addresses are removed.



Expected results:

Only the eth0:1 secondary IP should be removed.



Additional info:

Appears to be related to the fix put in for BZ 1266861 ?
Comment 11 errata-xmlrpc 2016-05-10 21:07:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0951.html

Note You need to log in before you can comment on or make changes to this bug.