Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1267026 - [Docs] [Director] Director Installation and Usage Guide, section 6.3.3
Summary: [Docs] [Director] Director Installation and Usage Guide, section 6.3.3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 7.0 (Kilo)
Hardware: All
OS: Linux
medium
medium
Target Milestone: async
: 7.0 (Kilo)
Assignee: Dan Macpherson
QA Contact: Radek Bíba
URL:
Whiteboard:
: 1253271 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-28 20:49 UTC by Dan Yocum
Modified: 2016-01-17 23:19 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-17 23:19:46 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dan Yocum 2015-09-28 20:49:34 UTC
Instructions state:

chmod 0600 /etc/ahc-tools/ahc-tools.conf

However, running ahc-report as user stack, this error is issued:

[stack@director1 ~]$ ahc-report --full
Traceback (most recent call last):
  File "/bin/ahc-report", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/ahc_tools/report.py", line 90, in main
    CONF(args=args, default_config_files=utils.DEFAULT_CONF_FILES)
  File "/usr/lib/python2.7/site-packages/oslo_config/cfg.py", line 1860, in __call__
    self._namespace._files_permission_denied)
oslo_config.cfg.ConfigFilesPermissionDeniedError: Failed to open some config files: /etc/ahc-tools/ahc-tools.conf


I suspect that either 'sudo' must be used to run the report *or* the config file perms should be more relaxed.

Comment 2 Dan Macpherson 2015-09-29 00:46:29 UTC
Hi Dan,

Confirming that you need to run ahc-report with sudo. Will make a docs update for that this week.

Comment 4 hrosnet 2015-09-30 10:13:40 UTC
I believe this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1253271

Comment 5 Dan Macpherson 2015-10-01 02:20:41 UTC
*** Bug 1253271 has been marked as a duplicate of this bug. ***

Comment 7 Andrew Dahms 2015-11-12 02:19:45 UTC
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?

Comment 8 Radek Bíba 2015-11-12 11:35:28 UTC
Easy fix. Verified.

Comment 9 Andrew Dahms 2016-01-17 23:19:46 UTC
This content is live on the Customer Portal.

Closing.


Note You need to log in before you can comment on or make changes to this bug.