Bug 126704 - Openoffice Help tells you to install fonts using spadmin, spadmin is nowhere to be found.
Openoffice Help tells you to install fonts using spadmin, spadmin is nowhere ...
Status: CLOSED DUPLICATE of bug 126701
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 19:40 EDT by Sindre Pedersen Bjørdal
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-15 15:09:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2004-06-24 19:40:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040510 Epiphany/1.2.4

Description of problem:
If you press help in OpenOffice.org and search for fonts, you'll get
instrictions telling you how to install fonts in UNIX. These
instructions will tell you to use a tool called spadmin, which seems
to be a tool used to add fonts in openoffice.org.

Here's the text for adding fonts:
"Adding Fonts:

You can integrate additional fonts in the OpenOffice.org software.
Fonts which you integrate are available exclusively to the
OpenOffice.org software and can be used with various Xservers without
your having to install them there. To make the fonts available to
other programs as well, proceed as usual by adding the fonts to your
Xserver. The OpenOffice.org software can display and print out
PostScript Type1 fonts as well as TrueType fonts (including TrueType
Collections).

To integrate additional fonts in the OpenOffice.org software, proceed
as follows:

1.Go to the {installpath}/program directory.
2.Enter: ./spadmin
3.Click Fonts.
4.The dialog lists all fonts added for the OpenOffice.org software.
You can select and remove fonts using the Remove button or add new
fonts with the Add button.
5.Click Add. The Add Fonts dialog appears.
6.Enter the directory from which you want to add the fonts. Press the
... button and select the directory from the path selection dialog or
enter the directory directly.
7.A list of the fonts from this directory appears. Select the fonts
you want to add. To add all the fonts, click Select All.
8.With the Create soft links only check box you can determine whether
the fonts are to be copied into the OpenOffice.org directory or only
symbolic links are to be created there. If the fonts to be added are
on a data medium that is not always available (such as a CD-ROM), you
must copy the fonts.
9.Click OK. The fonts will now be added.

In the case of a Server Installation, the fonts are installed in that
installation if possible. If the user has no write access rights, the
fonts will be installed in the corresponding Workstation Installation
so that only the user who installed them can access them."

These insctructions are clearly wrong, as the fedora core 2 packages
of openoffice.org don't even include spadmin. To my knowledge
openoffice.org uses fontconfig for fonts. The help file should help
users the fedora way. 

The same goes for instructions on how to remove fonts. They too are
wrongly telling the user to use spadmin. 

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Open an openoffice.org application like writer. 
2. Press Help > Contents. 
3. Search for fonts.
4. Read about adding fonts in UNIX. 
    

Additional info:
Comment 1 Dan Williams 2004-07-09 11:06:07 EDT

*** This bug has been marked as a duplicate of 126701 ***

Note You need to log in before you can comment on or make changes to this bug.