Bug 1267160 - Black screen will occur when install rhel7.2 on xen host via remote rhel7 connection
Summary: Black screen will occur when install rhel7.2 on xen host via remote rhel7 con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.2
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1271478 (view as bug list)
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-09-29 08:02 UTC by mxie@redhat.com
Modified: 2016-11-04 01:58 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 01:58:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
black screen after click "install RHEL7.2 option" (30.61 KB, image/png)
2015-09-29 08:02 UTC, mxie@redhat.com
no flags Details
w2003SP2 will hang at windows setup insterface.png (17.65 KB, image/png)
2015-10-14 03:37 UTC, mxie@redhat.com
no flags Details
virt-manager-1.2.1-8-debug.log (42.03 KB, text/plain)
2015-10-14 03:37 UTC, mxie@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2269 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2016-11-03 13:34:19 UTC

Description mxie@redhat.com 2015-09-29 08:02:09 UTC
Created attachment 1078200 [details]
black screen after click "install RHEL7.2 option"

Description of problem:
Black screen will occur when install rhel7.2 on xen host via remote rhel7 connection

Version-Release number of selected component (if applicable):
libvirt-1.2.17-11.el7.x86_64
qemu-kvm-1.5.3-104.el7.x86_64/qemu-kvm-rhev-2.3.0-26.el7.x86_64
virt-manager-1.2.1-7.el7.noarch
Host:RHEL-7.2-20150924.0

How reproducible:
100%

Steps to Reproduce:
1.Ensure xen server could be access
2.Run virt-manager. Add a new connect to xen host by clicking "File->Add Connection", select "Xen" in Hypervisor, check the "Connect to remote host" and input the hostname, then click "Connect".
3.Create a new guest by clicking the "Create a new virtual machine" icon and select "Local install media(ISO or CDROM)" then click forward and select rhel7.2.iso, then keep all the settings default until finish.
4.Enter into installation interface and click option "Install Red Hat Enterprise Linux 7.2", then Black srceen will occur even if waiting for a long time

Actual results:
As description

Expected results:
Could install rhel7.2 on xen host via remote rhel7 connection successfully

Additional info:
1.If install rhel7.2 on guest in xen virt-manager diectly, there isn't black srceen during installation

Comment 2 Pavel Hrdina 2015-09-29 13:40:44 UTC
Please provide debug logs from virt-manager (run 'virt-manager --debug' from console) and information about the XEN host system.

Comment 3 mxie@redhat.com 2015-10-14 03:35:46 UTC
(In reply to Pavel Hrdina from comment #2)
> Please provide debug logs from virt-manager (run 'virt-manager --debug' from
> console) and information about the XEN host system.

Sorry for late updating log
I meet a similar problem when install W2003SP2 x64 on xen host via remote rhel7 connection, the installation will hang at windows setup interface, details please refer to screenshot "w2003SP2 will hang at windows setup insterface.png" and log "virt-manager-1.2.1-8-debug.log"

Comment 4 mxie@redhat.com 2015-10-14 03:37:07 UTC
Created attachment 1082679 [details]
w2003SP2 will hang at windows setup insterface.png

Comment 5 mxie@redhat.com 2015-10-14 03:37:49 UTC
Created attachment 1082680 [details]
virt-manager-1.2.1-8-debug.log

Comment 6 Pavel Hrdina 2015-11-03 15:41:48 UTC
Upstream commit:

commit 5c3758142dadf291aeb52129a511fe9b2e240a85
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Tue Nov 3 13:11:19 2015 +0100

    virt-install: always enable pae for xen hvm 64bit guest
    
    According to xen documentation 64bit guest has to have pae enabled in
    order to be able to run 64bit OS.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1267160
    
    Signed-off-by: Pavel Hrdina <phrdina@redhat.com>

Comment 7 Pavel Hrdina 2015-11-13 09:22:17 UTC
*** Bug 1271478 has been marked as a duplicate of this bug. ***

Comment 8 Mike McCune 2016-03-28 23:17:33 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 10 XiaoyunHu 2016-06-20 03:16:52 UTC
I can reproduce this bug with package:
virt-manager-1.2.1-8.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.3.2-1.el7.noarch

Steps:
1.Ensure xen server could be access
2.Run virt-manager. Add a new connect to xen host by clicking "File->Add Connection", select "Xen" in Hypervisor, check the "Connect to remote host" and input the hostname, then click "Connect".
3.Create a new guest by clicking the "Create a new virtual machine" icon and select "Local install media(ISO or CDROM)" then click forward and select rhel7.2.iso, then keep all the settings default until finish.
4.Enter into installation interface and click option "Install Red Hat Enterprise Linux 7.2".

Results:
After step4 , black screen doesn't occur and the guest can be installed successfully.

Comment 12 errata-xmlrpc 2016-11-04 01:58:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html


Note You need to log in before you can comment on or make changes to this bug.