Bug 1271478 - RHEL6.7x64 unable to boot due to kernel have no pae feature for CPU on xen host via remote rhel7 connection
RHEL6.7x64 unable to boot due to kernel have no pae feature for CPU on xen ho...
Status: CLOSED DUPLICATE of bug 1267160
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-14 02:38 EDT by mxie@redhat.com
Modified: 2015-11-13 04:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 04:22:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhel6.7 have no kernel feature pae for CPU.png (17.77 KB, image/png)
2015-10-14 02:38 EDT, mxie@redhat.com
no flags Details
rhel6.7x64_on_xen_host_via_remote_rhel7_connection.xml (1.44 KB, text/plain)
2015-10-14 02:40 EDT, mxie@redhat.com
no flags Details
rhel6.7-x64-virt-manager-debug.log (33.87 KB, text/plain)
2015-10-14 02:41 EDT, mxie@redhat.com
no flags Details
rhel6.7x64_on_xen.xml (1.45 KB, text/plain)
2015-10-14 02:42 EDT, mxie@redhat.com
no flags Details

  None (edit)
Description mxie@redhat.com 2015-10-14 02:38:15 EDT
Created attachment 1082708 [details]
rhel6.7 have no kernel feature pae for CPU.png

Description of problem:
RHEL6.7x64 unable to boot due to kernel have no pae feature for CPU on xen host via remote rhel7 connection

Version-Release number of selected component (if applicable):
libvirt-1.2.17-13.el7.x86_64
qemu-kvm-1.5.3-104.el7.x86_64
virt-manager-1.2.1-8.el7.noarch
Host:RHEL-7.2-20151008.0

How reproducible:
100%

Steps to Reproduce:
1. Ensure xen server could be access
2. Run virt-manager. Add a new connect to xen host by clicking "File->Add Connection", select "Xen" in Hypervisor, check the "Connect to remote host" and input the hostname, then click "Connect".
3. Create a new guest by clicking the "Create a new virtual machine" icon and select "Local install media(ISO or CDROM)" then click forward and select rhel6.7x64.iso, then keep all the settings default until finish.
4.Enter into installation interface and click option "Install or upgrade an existing system", then prompt "this kernel requires the following feature not present on the CPU: pae, unable to boot", please refer to screenshot "rhel6.7 have no kernel feature pae for CPU.png"
5.Check the dumpxml for rhel6.7x64 guest which built on xen host via remote rhel7 connection as below, it really have no kernel feature "pae", please refer to guest xml "rhel6.7x64_on_xen_host_via_remote_rhel7_connection.xml", more details refer to virt-manager debug log "rhel6.7-x64-virt-manager-debug.log"
  <features>
    <acpi/>
    <apic/>
  </features>

Actual results:
As description

Expected results:
RHEL6.7x64 could be installed normally on xen host via remote rhel7 connection

Additional info:
1.If install rhel6.7-x64 on guest in xen virt-manager diectly, it could be installed normally and kernel have pae feature for CPU in xml, please refer to guest xml "rhel6.7x64_on_xen.xml"

  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
Comment 1 mxie@redhat.com 2015-10-14 02:40 EDT
Created attachment 1082710 [details]
rhel6.7x64_on_xen_host_via_remote_rhel7_connection.xml
Comment 2 mxie@redhat.com 2015-10-14 02:41 EDT
Created attachment 1082711 [details]
rhel6.7-x64-virt-manager-debug.log
Comment 3 mxie@redhat.com 2015-10-14 02:42 EDT
Created attachment 1082712 [details]
rhel6.7x64_on_xen.xml
Comment 5 Pavel Hrdina 2015-11-13 04:22:17 EST

*** This bug has been marked as a duplicate of bug 1267160 ***

Note You need to log in before you can comment on or make changes to this bug.