Bug 1267259 - New/Edit Cluster dialog ui is inconsistent
New/Edit Cluster dialog ui is inconsistent
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.1.1
: ---
Assigned To: Alexander Wels
Lucie Leistnerova
:
Depends On:
Blocks: 1266035 1298850
  Show dependency treegraph
 
Reported: 2015-09-29 09:18 EDT by Karolína Hajná
Modified: 2017-04-21 05:42 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-21 05:42:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: exception+
rule-engine: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)
General tab (54.29 KB, image/png)
2015-09-29 09:19 EDT, Karolína Hajná
no flags Details
Optimization tab (57.91 KB, image/png)
2015-09-29 09:19 EDT, Karolína Hajná
no flags Details
Scheduling policy (75.02 KB, image/png)
2015-09-29 09:20 EDT, Karolína Hajná
no flags Details
Console tab (41.32 KB, image/png)
2015-09-29 09:20 EDT, Karolína Hajná
no flags Details
Fencing policy tab (52.64 KB, image/png)
2015-09-29 09:21 EDT, Karolína Hajná
no flags Details
After adding 3 properties (9.83 KB, image/png)
2016-06-15 06:15 EDT, Lukas Svaty
no flags Details
After adding 4th property (12.32 KB, image/png)
2016-06-15 06:15 EDT, Lukas Svaty
no flags Details
option_text_moved (82.77 KB, image/png)
2017-01-23 07:22 EST, Lucie Leistnerova
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 55417 master MERGED webadmin: cluster popup update 2016-03-30 08:46 EDT
oVirt gerrit 59407 master MERGED webadmin: cluster scheduling policy layout 2016-06-21 10:12 EDT
oVirt gerrit 71037 master ABANDONED webadmin: cluster layout 2017-01-24 08:39 EST
oVirt gerrit 71104 master MERGED webadmin: Fix label click on checkbox. 2017-02-14 13:08 EST
oVirt gerrit 72305 ovirt-engine-4.1 MERGED webadmin: Fix label click on checkbox. 2017-02-14 17:26 EST

  None (edit)
Description Karolína Hajná 2015-09-29 09:18:50 EDT
Description of problem:
The ui in New/Edit Cluster dialog is inconsistent. I attached screenshots with highlighted components which should be moved, resized etc. Everything is described in the screenshots.

Version-Release number of selected component (if applicable):
3.6.0-15

How reproducible:
100%

Steps to Reproduce:
1. Open New/Edit Cluster and look on all tabs.

Actual results:
inconsistent ui

Expected results:
consistent ui
Comment 1 Karolína Hajná 2015-09-29 09:19 EDT
Created attachment 1078326 [details]
General tab
Comment 2 Karolína Hajná 2015-09-29 09:19 EDT
Created attachment 1078327 [details]
Optimization tab
Comment 3 Karolína Hajná 2015-09-29 09:20 EDT
Created attachment 1078328 [details]
Scheduling policy
Comment 4 Karolína Hajná 2015-09-29 09:20 EDT
Created attachment 1078329 [details]
Console tab
Comment 5 Karolína Hajná 2015-09-29 09:21 EDT
Created attachment 1078330 [details]
Fencing policy tab
Comment 7 Red Hat Bugzilla Rules Engine 2015-11-30 16:00:49 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Lukas Svaty 2016-06-15 06:14:00 EDT
tested in ovirt-engine-webadmin-portal-4.0.0.4-0.1.el7ev.noarch

Incosistent behaviour on length of fields when adding properties to scheduling policies see screenshots add before and after adding new property
Comment 10 Red Hat Bugzilla Rules Engine 2016-06-15 06:14:07 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 11 Lukas Svaty 2016-06-15 06:15 EDT
Created attachment 1168303 [details]
After adding 3 properties
Comment 12 Lukas Svaty 2016-06-15 06:15 EDT
Created attachment 1168304 [details]
After adding 4th property
Comment 14 Sandro Bonazzola 2016-12-12 08:55:14 EST
The fix for this issue should be included in oVirt 4.1.0 beta 1 released on December 1st. If not included please move back to modified.
Comment 15 Lucie Leistnerova 2017-01-23 07:21:56 EST
If last option has '?' help, text moves up.
Treshold in Fencing Policy tab is not moved left/down.
See attachment.

tested in ovirt-engine-webadmin-portal-4.1.0.2-0.1.el7.noarch
Comment 16 Red Hat Bugzilla Rules Engine 2017-01-23 07:22:02 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 17 Lucie Leistnerova 2017-01-23 07:22 EST
Created attachment 1243574 [details]
option_text_moved
Comment 18 Red Hat Bugzilla Rules Engine 2017-01-23 07:24:43 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 19 Lucie Leistnerova 2017-02-20 10:30:09 EST
Options with '?' are good now. 
I talked to Alexander and the Treshold should stay on the right side because most inputs/select boxes, that corresponds with some checkbox, are on the right.

verified in ovirt-engine-webadmin-portal-4.1.1.2-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.