Bug 126745 - gnome-keyboard-properties sets keyboard delay and rate as float instead of int
gnome-keyboard-properties sets keyboard delay and rate as float instead of int
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Depends On:
  Show dependency treegraph
Reported: 2004-06-25 12:41 EDT by Scott Gifford
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-11 17:34:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Scott Gifford 2004-06-25 12:41:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
When I run gnome-keyboard-properties (via the Preferences/Keyboard
menu option) and try to adjust the keyboard repeat rate or delay, I
get a popup error like this:

    Type mismatch: Expected `int' got `float' for key

This error continues to occur when I start X.

I can correct this by hand, and get the results I want, by setting the
properties as integers:

    gconftool-2 -t int -s /desktop/gnome/peripherals/keyboard/delay 500
    gconftool-2 -t int -s /desktop/gnome/peripherals/keyboard/rate 20

As a side note, when the repeat rate gets screwed up, keys repeat so
quickly that it's impossible to type, making it very difficult to
correct the problem by hand.  A limit on the repeat rate would be a
good way of mitigating the damage from bugs like this.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Select the Preferences/Keyboard menu item
2. Select the Keyboard tab
3. Below Repeat Keys, select "Key presses repeat when key is held down".
4. Move the sliders for Delay or Rate.

Actual Results:  An error pops up, and all keys repeat twice
immediately upon pressing them.

Expected Results:  Setting the proper keyboard repeat properties.

Additional info:
Comment 1 Paul Eden 2004-09-17 11:27:16 EDT
I have the same problem.
Comment 2 Paul Eden 2004-09-17 11:37:34 EDT
I have tried to downgrade libgnome 
rpm -e libgnome libgnome-devel --nodeps;  
rpm -ivh libgnome-2.6.0-2.i386.rpm libgnome-devel-2.6.0-2.i386.rpm

to which did not fix the problem.

This downgrade was suggested in bug 124207 which is a duplicate of
this one.
Comment 3 Paul Eden 2004-09-17 11:40:15 EDT
I take that back.  The problem is now fixed after downgrading to
libgnome 2.6.0-2.
Comment 4 Paul Eden 2004-09-17 11:50:15 EDT

If I use /usr/bin/gnome-keyboard-properties and change either the
delay or speed in the Repeat keys section the error reoccurs (pop up
box with error message and repeat keys does not work).

gconftool-2 -t int -s /desktop/gnome/peripherals/keyboard/delay 500
gconftool-2 -t int -s /desktop/gnome/peripherals/keyboard/rate 20
and then using /usr/bin/gnome-keyboard-properties and only checking
"Key presses repeat when key is down" fixes the problem again.

Note this manual fix also works after upgrading libgnome to 2.6.0-3.
Comment 5 Marco Pesenti Gritti 2004-11-04 09:46:55 EST
Can you give me the output of:

| grep delay
Comment 6 Paul Eden 2004-11-04 10:52:30 EST
Sorry, not anymore.  I have already changed the OS on that machine.
Comment 7 Scott Gifford 2004-11-05 11:35:52 EST
[root@gifford gifford]# cat
|grep delay
        <entry name="delay" mtime="1086833025" type="schema"
stype="int" owner="gnome">
Comment 8 Matthew Miller 2005-04-26 12:09:10 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 9 Ray Strode [halfline] 2005-05-11 17:34:16 EDT

This bug is being closed because it has been in the NEEDINFO state for a long
time now.  Feel free to reopen the bug report if the problem still happens for
you and you can provide any information that was requested.

Note You need to log in before you can comment on or make changes to this bug.