Bug 1267460 - xchat-gnome FTBFS: automake: error: cannot open < gnome-doc-utils.make: No such file or directory
xchat-gnome FTBFS: automake: error: cannot open < gnome-doc-utils.make: No su...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xchat-gnome (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
: Patch
: 1308248 (view as bug list)
Depends On:
Blocks: F24FTBFS
  Show dependency treegraph
 
Reported: 2015-09-30 02:30 EDT by Jitka Plesnikova
Modified: 2016-03-07 14:00 EST (History)
4 users (show)

See Also:
Fixed In Version: xchat-gnome-0.26.2-22.git40c5bf988.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 14:00:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix build with gnome-common 3.18 (#1267460) (1.25 KB, patch)
2016-02-18 21:36 EST, Yaakov Selkowitz
no flags Details | Diff

  None (edit)
Description Jitka Plesnikova 2015-09-30 02:30:49 EDT
Description of problem:
Package xchat-gnome fails to build from source in rawhide.

Version-Release number of selected component (if applicable):
0.26.2-20.git40c5bf988.fc23

Steps to Reproduce:
koji build --scratch f24 xchat-gnome-0.26.2-20.git40c5bf988.fc23.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://apps.fedoraproject.org/koschei/package/xchat-gnome

Details about the first build which failed:
https://apps.fedoraproject.org/koschei/build/888392
Comment 1 Petr Pisar 2015-10-01 02:25:26 EDT
The error message is:

+ ./autogen.sh
[...]
automake: error: cannot open < gnome-doc-utils.make: No such file or directory
autoreconf: automake failed with exit status: 1

It looks like a plain file name is expected while shell redirection `< gnome-doc-utils.make' was supplied.

Difference between working and failing build root is:

        gnome-common 	3.14.0-3.fc23 	> 	3.18.0-1.fc24
	at-spi2-atk-devel 	2.17.90-1.fc24 	> 	2.18.0-1.fc24
	at-spi2-atk 	2.17.90-1.fc24 	> 	2.18.0-1.fc24
	kernel-headers 	4.3.0-0.rc1.git4.1.... 	> 	4.3.0-0.rc2.git0.1....
	at-spi2-core-devel 	2.17.90-1.fc24 	> 	2.18.0-1.fc24
	at-spi2-core 	2.17.90-1.fc24 	> 	2.18.0-1.fc24
Comment 2 Petr Pisar 2016-02-17 07:16:30 EST
*** Bug 1308248 has been marked as a duplicate of this bug. ***
Comment 3 Yaakov Selkowitz 2016-02-18 21:36 EST
Created attachment 1128388 [details]
Fix build with gnome-common 3.18 (#1267460)

(In reply to Petr Pisar from comment #1)
> The error message is:
> 
> + ./autogen.sh
> [...]
> automake: error: cannot open < gnome-doc-utils.make: No such file or
> directory
> autoreconf: automake failed with exit status: 1
> 
> It looks like a plain file name is expected while shell redirection `<
> gnome-doc-utils.make' was supplied.

This is automake complaining because help/Makefile.am has the following:

include $(top_srcdir)/gnome-doc-utils.make

However, the file isn't there because...

> Difference between working and failing build root is:
> 
>         gnome-common 	3.14.0-3.fc23 	> 	3.18.0-1.fc24

This is the culprit; gnome-doc-utils support was removed prior to 3.18:

https://git.gnome.org/browse/gnome-common/commit/?id=1f60e9536dd8ac71a799d60eb128c6c928c67639

Patch for rawhide attached (tested in mock).
Comment 4 Jan Kurik 2016-02-24 08:48:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Fedora Admin XMLRPC Client 2016-02-26 21:04:15 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2016-02-29 11:29:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.