Bug 1267483 - [DOCS] [3.1] [Feature] Document OpenShift Console Logging feature
[DOCS] [3.1] [Feature] Document OpenShift Console Logging feature
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: brice
chunchen
Vikram Goyal
:
: 1255592 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 03:30 EDT by Vikram Goyal
Modified: 2017-03-08 13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 20:08:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikram Goyal 2015-09-30 03:30:32 EDT
Display logs (realtime back to a line #) in the OSE console for Builds & Pods (no aggregation / ELK integration).

I think this is related with this Developer Trello Card:
https://trello.com/c/dQTSKkb0/153-expose-logging-capabilities-to-users-and-application-administrators

Please review what actual capabilities are being implemented in the final product as opposed to what has been promised by this card.
Comment 2 brice 2015-11-02 01:18:56 EST
PR here:

https://github.com/openshift/openshift-docs/pull/1129
Comment 3 brice 2015-11-13 00:13:50 EST
Hi, Chunyun

Can I ask for a QE review of this aggregating logging doc. This link will take you to the PR:

https://github.com/openshift/openshift-docs/pull/1129

Thanks, much.
Comment 4 chunchen 2015-11-13 05:33:50 EST
@brice Have added a comment for PR/1129, please help to have a look.
Comment 5 chunchen 2015-11-13 05:35:50 EST
And will verify this bug when the PR is merged.
Comment 6 openshift-github-bot 2015-11-17 01:05:43 EST
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/ecf23204f9986013f58ba758dc8631eb657975b7
Merge pull request #1129 from bfallonf/BZ1267483

Bug 1267483 : added file on configuring EFK
Comment 7 brice 2015-11-17 01:20:39 EST
Chunyen,

The mentioned PR has merged. I have implemented your suggestion.

Let me know if there's anything else, and it can maybe be completed in a follow-up PR.

Thanks!
Comment 8 chunchen 2015-11-17 23:13:58 EST
The below links are unavailable in this Doc:

1) "Create a *secret* for the deployer. The secret can be configured for your instance, but specific for the deployer."
-------- the "secret" link is unreachable

2) "Create the deployer *service account*:"
-------- the "service account" link is unreachable

3) "The EFK stack is deployed *using a template*."
-------- the "using a template" link is unreachable

4) "You can use any volume type, such as *NFS*."
-------- the "NFS" link is unreachable

Others are LGTM.
Comment 9 brice 2015-11-17 23:56:22 EST
Chunyen,

Were you using the GitHub site to check these, by any chance? Because of the way links work in our docs, they don't work on the GH site, but they work fine on the OpenShift site. You can see it here:

https://docs.openshift.com/enterprise/3.1/install_config/aggregate_logging.html

Before we submit a PR and ask for review, we do a local build to check links, etc., so then we know it's ok to submit the PR. It's then available on the GH site, but not the OpenShift site until it's merged, and picked for the next release. (Hope this makes sense.)
Comment 10 chunchen 2015-11-18 23:21:16 EST
brice, 

Thanks for your explanation, checked the docs on OpenShift site, they are ok, so mark it as verified.
Comment 11 brice 2015-11-19 20:08:57 EST
Thanks, Chunyun.
Comment 12 brice 2016-01-14 01:59:39 EST
*** Bug 1255592 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.