This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267503 - Unable to add/remove objects from PM Proxy Preference list in Power Management tab in Edit Host
Unable to add/remove objects from PM Proxy Preference list in Power Managemen...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alexander Wels
Lukas Svaty
infra
:
: 1267502 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 04:19 EDT by Martin Perina
Modified: 2016-02-10 14:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: In previous version users were able to modify Power Management Proxy Preference of a host only using REST API. The webadmin UI was only showing current values. Reason: Result: In new version users are now able to modify PM Proxy Preference in Advanced Options inside Power Management tab of Host Detail dialog. Valid options of PM Proxy Preference list are: cluster - fencing proxy host is selected from the same cluster as non responsive host dc - fencing proxy host is selected from the same data center as non responsive host other_dc - fencing proxy host is selected from the different datacenter than non responsive host belongs to The items in PM Proxy Preference are selected by defined order, so for examle PM Proxy Preference list contains: 1. cluster 2. dc Than engine tries to select fencing proxy from the same cluster as non responsive host first and if no proxy can be selected then engine tries to select fencing proxy from other clusters in the same data center as non responsive host.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:19:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47482 master MERGED webadmin: PM Proxy preferences list Never
oVirt gerrit 47610 ovirt-engine-3.6 MERGED webadmin: PM Proxy preferences list Never

  None (edit)
Description Martin Perina 2015-09-30 04:19:16 EDT
Description of problem:

We forgot to add the ability to add/remove objects from PM Proxy Preference list in Power Management tab in Edit Host, so if user for example needs to add "Other DC" to the list, he has to do that in REST API.

Version-Release number of selected component (if applicable):

oVirt 3.6.0 RC

How reproducible:

100%

Steps to Reproduce:
1. Open New Host dialog, go to Power Management tab, enable power managmement and show Advanced Parameters
2. The order of objects in Power Management Proxy Preference list can be changed, but add/removing objects is not possible

Actual results:

Adding/removing objects from Power Management Proxy Preference list is not possible

Expected results:

Adding/removing objects from Power Management Proxy Preference list is possible,
allowed objects in the list are specified in FenceProxySourceType enum.


Additional info:
Comment 1 Martin Perina 2015-10-05 04:19:26 EDT
*** Bug 1267502 has been marked as a duplicate of this bug. ***
Comment 2 Yaniv Lavi (Dary) 2015-10-29 08:36:12 EDT
In oVirt testing is done on single release by default. Therefore I'm removing the 4.0 flag. If you think this bug must be tested in 4.0 as well, please re-add the flag. Please note we might not have testing resources to handle the 4.0 clone.
Comment 3 Lukas Svaty 2015-11-26 10:27:07 EST
verifeid in rhevm-webadmin-portal-3.6.1-0.2.el6.noarch
Comment 4 Sandro Bonazzola 2015-12-16 07:19:25 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.