Bug 1267508 - [RFE] Replace python-cheetah with python-jinja2 within ovirt-engine
[RFE] Replace python-cheetah with python-jinja2 within ovirt-engine
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Services (Show other bugs)
4.0.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Rafael Martins
Jiri Belka
http://jinja.pocoo.org/
: FutureFeature
Depends On:
Blocks: RHEV_from_3_6_to_4_0_Migration_Tracker 1323580
  Show dependency treegraph
 
Reported: 2015-09-30 04:29 EDT by Sandro Bonazzola
Modified: 2016-07-07 21:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: ovirt 4.0.0 alpha1
Doc Type: Enhancement
Doc Text:
With this update, python-cheetah was replaced with python-jinja2 as the template-engine for services configuration files. This update was required as python-cheetah stopped receiving updates in 2012 and is not available in Red Hat Enterprise Linux 7.2.
Story Points: ---
Clone Of:
: 1323580 (view as bug list)
Environment:
Last Closed: 2016-07-05 03:42:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
pnovotny: testing_plan_complete-
ylavi: planning_ack+
sbonazzo: devel_ack+
pnovotny: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 52885 master MERGED packaging: services: ovirt-engine: replace cheetah with jinja2 2016-02-02 03:55 EST

  None (edit)
Description Sandro Bonazzola 2015-09-30 04:29:14 EDT
ovirt-engine is using python-cheetah for handling the templates used within the project.

python-cheetah didn't receive updates since 2012 and is not available on RHEL 7.2.

Since we're dropping el6 support in 4.0 we should migrate to a template engine available in el7 like python-jinja2[1] which is
available in 7.2 and still actively developed (last commit is on August
6th).

[1] http://jinja.pocoo.org/
Comment 1 Sandro Bonazzola 2015-09-30 04:30:26 EDT
Juan if we migrate to python-jinja2 will it require changes on Java side as well?
Comment 2 Juan Hernández 2015-09-30 04:33:38 EDT
I believe it won't require changes in the Java side.
Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 07:00:17 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Jiri Belka 2016-07-01 05:29:23 EDT
ok,

[root@jb-rhevm40 ~]# rpm -qR ovirt-engine-backend | grep python-
python-jinja2
[root@jb-rhevm40 ~]# rpm -qa \*cheetah\*
[root@jb-rhevm40 ~]# rpm -q ovirt-engine-backend
ovirt-engine-backend-4.0.0.6-0.1.el7ev.noarch
Comment 5 Sandro Bonazzola 2016-07-05 03:42:57 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.