Bug 1267532 - Data Tiering:CLI crashes with segmentation fault when user tries "gluster v tier" command
Data Tiering:CLI crashes with segmentation fault when user tries "gluster v t...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.4
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Manikandan
bugs@gluster.org
:
Depends On:
Blocks: 1260923 1267539
  Show dependency treegraph
 
Reported: 2015-09-30 06:40 EDT by nchilaka
Modified: 2016-09-20 00:28 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1267539 (view as bug list)
Environment:
Last Closed: 2015-10-14 06:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2015-09-30 06:40:20 EDT
Description of problem:
======================
as soon as i executed "gluster v tier" command , there is a CLI crash seen with segmentation fault
[root@zod glusterfs]# gluster v tier
Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>

Segmentation fault (core dumped)
[root@zod glusterfs]# gluster v
unrecognized command




Version-Release number of selected component (if applicable):
=============================================================
[root@zod glusterfs]# rpm -qa|grep gluster
glusterfs-api-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-debuginfo-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-client-xlators-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-server-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-cli-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-libs-3.7.4-0.63.git6667478.el7.centos.x86_64
gglusterfs-fuse-3.7.4-0.63.git6667478.el7.centos.x86_64
l[root@zod glusterfs]# gluster --version
glusterfs 3.7.4 built on Sep 30 2015 01:42:31
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@zod glusterfs]# 

I created a tier vol prior to this
Steps to Reproduce:
==================
1.issue a "gluster v tier"  command and hit the enter button
Comment 1 nchilaka 2015-09-30 06:59:43 EDT
core and sosreports @
[root@rhsqe-repo.lab.eng.blr.redhat.com:/home/repo/sosreports/bug.1267532
Comment 2 Manikandan 2015-10-01 05:15:11 EDT
Patch posted 3.7 -> http://review.gluster.org/#/c/12259/
Comment 3 Pranith Kumar K 2015-10-14 06:27:30 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 4 Pranith Kumar K 2015-10-14 06:37:24 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.