Bug 1267539 - Data Tiering:CLI crashes with segmentation fault when user tries "gluster v tier" command
Data Tiering:CLI crashes with segmentation fault when user tries "gluster v t...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Manikandan
bugs@gluster.org
: Reopened
Depends On: 1267532
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-30 07:04 EDT by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1267532
Environment:
Last Closed: 2016-06-16 09:39:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-09-30 07:04:45 EDT
+++ This bug was initially created as a clone of Bug #1267532 +++

Description of problem:
======================
as soon as i executed "gluster v tier" command , there is a CLI crash seen with segmentation fault
[root@zod glusterfs]# gluster v tier
Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>

Segmentation fault (core dumped)
[root@zod glusterfs]# gluster v
unrecognized command




Version-Release number of selected component (if applicable):
=============================================================
[root@zod glusterfs]# rpm -qa|grep gluster
glusterfs-api-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-debuginfo-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-client-xlators-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-server-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-cli-3.7.4-0.63.git6667478.el7.centos.x86_64
glusterfs-libs-3.7.4-0.63.git6667478.el7.centos.x86_64
gglusterfs-fuse-3.7.4-0.63.git6667478.el7.centos.x86_64
l[root@zod glusterfs]# gluster --version
glusterfs 3.7.4 built on Sep 30 2015 01:42:31
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@zod glusterfs]# 

I created a tier vol prior to this
Steps to Reproduce:
==================
1.issue a "gluster v tier"  command and hit the enter button

--- Additional comment from nchilaka on 2015-09-30 06:59:43 EDT ---

core and sosreports @
[root@rhsqe-repo.lab.eng.blr.redhat.com:/home/repo/sosreports/bug.1267532
Comment 1 Niels de Vos 2016-06-16 09:39:10 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.