This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267674 - [RFE] Show partial failure status
[RFE] Show partial failure status
Status: CLOSED NOTABUG
Product: Copr
Classification: Community
Component: frontend (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Miroslav Suchý
:
: 1310186 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 11:47 EDT by Orion Poplawski
Modified: 2016-02-29 08:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 08:24:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2015-09-30 11:47:37 EDT
Description of problem:

Currently the status of a build is either failed if any build failed or succeeded if they all succeeded.  I think it would be very helpful if there was a partial status that indicated a mix of failed and succeeded build.
Comment 1 clime 2016-01-28 07:38:07 EST
Where exactly should this kind of mix status pop up? I think the current differentiation in the build overviews is ok because it is simple enough. You can always get the necessary details if you click on (go to detail of) the respective build.
Comment 2 Orion Poplawski 2016-01-28 14:29:35 EST
I think in for e.g.: https://copr.fedorainfracloud.org/coprs/orion/conda/builds/

the status for build 150906  should be something like:

1 failed, 6 succeeded
Comment 3 Miroslav Suchý 2016-02-24 04:22:19 EST
*** Bug 1310186 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Suchý 2016-02-24 04:26:34 EST
For this reason there is "Monitor" tab with matrix, which shows all the chroots and their status.
Comment 5 Orion Poplawski 2016-02-24 13:14:29 EST
I'm well aware of "monitor", I still think this is useful as otherwise I consider the current status as a lie.
Comment 6 clime 2016-02-29 08:24:01 EST
I like the simplicity of the current solution, maybe in future.

Note You need to log in before you can comment on or make changes to this bug.