Bug 1267884 - katello-installer --upgrade does not print error on stdout for an "Importing Errata" error
katello-installer --upgrade does not print error on stdout for an "Importing ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.1.1
x86_64 Linux
high Severity high (vote)
: GA
: --
Assigned To: Mike McCune
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-01 05:49 EDT by Pavel Moravec
Modified: 2016-07-27 07:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:27:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14241 None None None 2016-03-22 16:47 EDT

  None (edit)
Description Pavel Moravec 2015-10-01 05:49:57 EDT
Description of problem:
If "Importing Errata" part of the upgrade fails with logs:

[DEBUG 2015-09-17 18:31:34 main] Importing Errata
Updating Content Host Repositories my-host.example.com
There was an error updating Content Host my-host.example.com with id 31

then this error is not printed out to stdout. That gives the user wrong perception the upgrade went smooth.


Version-Release number of selected component (if applicable):
katello-installer-2.3.17-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. (unknown - have Satellite where updating content host repositories fail with above error)
2. run katello-installer --upgrade
3. Check its output and its logfile


Actual results:
stdout will claim upgrade went successfully
logfile will have errors like above


Expected results:
stdout needs to warn about the errors


Additional info:
Comment 2 Stephen Benjamin 2016-03-16 15:14:25 EDT
Created redmine issue http://projects.theforeman.org/issues/14241 from this bug
Comment 4 Mike McCune 2016-03-22 16:47:06 EDT
We are removing this from 6.2's upgrade steps here:

https://bugzilla.redhat.com/show_bug.cgi?id=1314695
Comment 5 Sachin Ghai 2016-06-16 04:21:23 EDT
Verified with upgrade from sat6.1.9 -> sat6.2 beta snap15.2.

I think errata_step from upgrade step has been removed and I don't see any related issue neither in logs not on console:

[root@qe-sat6-upgrade-rhel7 yum.repos.d]# satellite-installer --scenario satellite --upgrade 
Upgrading...
Upgrade Step: stop_services...
Upgrade Step: start_databases...
Upgrade Step: update_http_conf...
Upgrade Step: migrate_pulp...
Upgrade Step: fix_pulp_httpd_conf...
Upgrade Step: start_httpd...
Upgrade Step: start_qpidd...
Upgrade Step: start_pulp...
Upgrade Step: migrate_candlepin...
Upgrade Step: start_tomcat...
Upgrade Step: fix_katello_settings_file...
Upgrade Step: migrate_foreman...
Upgrade Step: remove_nodes_distributors...
Upgrade Step: Running installer...
Installing             Done                                               [100%] [..................................................................]
  The full log is at /var/log/foreman-installer/satellite.log
Upgrade Step: restart_services...
Upgrade Step: db_seed...
Upgrade Step: import_package_groups (this may take a while) ...
Upgrade Step: import_rpms (this may take a while) ...
Upgrade Step: import_distributions (this may take a while) ...
Upgrade Step: import_puppet_modules (this may take a while) ...
Upgrade Step: import_subscriptions (this may take a while) ...
Upgrade Step: elasticsearch_message...
Elasticsearch has been removed as a dependency.  The database files can be removed manually with #rm -rf /var/lib/elasticsearch.  Some packages are no longer needed and can be removed:  #rpm -e ruby193-rubygem-tire tfm-rubygem-tire elasticsearch sigar-java sigar snappy-java lucene4-contrib lucene4
Upgrade Step: remove_docker_v1_content (this may take a while) ...
Upgrade Step: update_puppet_repository_distributors (this may take a while) ...
Upgrade Step: remove_gutterball...
Katello upgrade completed!
Comment 6 Bryan Kearney 2016-07-27 07:27:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.