Bug 1268089 - Need to hide "Docker Images" tab from Red Hat Repositories
Need to hide "Docker Images" tab from Red Hat Repositories
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Partha Aji
sthirugn@redhat.com
http://projects.theforeman.org/issues...
: FutureFeature, Triaged
Depends On: 1199289
Blocks: 1190289
  Show dependency treegraph
 
Reported: 2015-10-01 15:12 EDT by Partha Aji
Modified: 2016-07-27 05:19 EDT (History)
9 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.15-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1199289
Environment:
Last Closed: 2016-07-27 05:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verification screenshot (63.36 KB, image/png)
2016-04-08 09:30 EDT, sthirugn@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14222 None None None 2016-04-22 11:42 EDT

  None (edit)
Description Partha Aji 2015-10-01 15:12:15 EDT
Currently CDN does not enforce docker image entitlements. Due to this "enabling" CDN based docker repositories does not make sense from Satellite perspective. Satellite should hide the "Docker Images" tab on Red Hat Repositories UI.
Comment 1 Bryan Kearney 2015-10-01 16:03:38 EDT
Upstream bug assigned to paji@redhat.com
Comment 2 Bryan Kearney 2015-10-01 16:03:40 EDT
Upstream bug component is Container Management
Comment 3 Bryan Kearney 2015-10-01 16:03:43 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/7796 has been closed
-------------
Partha Aji
Applied in changeset commit:katello|06bedb13fdf9da9fa56089227ff637c0b370cf23.
Comment 6 Tazim Kolhar 2016-01-05 07:22:55 EST
hi,

  please provide verification steps

thanks and regards,
Tazim
Comment 8 Partha Aji 2016-03-15 16:57:31 EDT
Created redmine issue http://projects.theforeman.org/issues/14222 from this bug
Comment 9 Bryan Kearney 2016-03-15 18:14:07 EDT
Upstream bug component is Content Management
Comment 10 Partha Aji 2016-03-18 14:52:05 EDT
Fix is in upstream -> Check these 2 comments for things to test .. 

http://imgur.com/7kfl0s4

https://github.com/Katello/katello/pull/5888#issuecomment-197587798
Comment 12 Brad Buckingham 2016-03-24 11:40:12 EDT
Moving this bug to POST, since the upstream PR was merged.
Comment 13 sthirugn@redhat.com 2016-04-08 09:28:55 EDT
Verified in satellite-6.2.0-7.0.beta.el7sat.noarch

1. there is no `Docker Images` tab in Red Hat Repositories (see screenshot)

2. There are no repository se tfor Red Hat Container Images (as suggested in Comment 10)

# hammer -u admin -p changeme repository-set list --organization-id=1 --product="Red Hat Container Images"
---|------|-----
ID | TYPE | NAME
---|------|-----
Comment 14 sthirugn@redhat.com 2016-04-08 09:30 EDT
Created attachment 1145140 [details]
Verification screenshot
Comment 16 errata-xmlrpc 2016-07-27 05:19:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.