Bug 1268259 - Ghostscript (via ImageMagick convert) takes extremely long to convert PDF to PNG
Ghostscript (via ImageMagick convert) takes extremely long to convert PDF to PNG
Status: CLOSED DUPLICATE of bug 1302121
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ghostscript (Show other bugs)
7.3
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
QE Internationalization Bugs
:
Depends On:
Blocks: 1289025 1305230
  Show dependency treegraph
 
Reported: 2015-10-02 06:54 EDT by Peter Bex
Modified: 2016-06-22 09:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-22 09:24:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bex 2015-10-02 06:54:57 EDT
Description of problem:

When using ImageMagick or GraphicsMagick's "convert" program to convert a PDF to PNG, ghostscript is invoked and takes several hours to convert an image. On newer versions of ghostscript this takes only a few seconds.

Version-Release number of selected component (if applicable):

ghostscript.x86-64-9.07-18.el7

How reproducible:


Steps to Reproduce:
1. With ImageMagick: "convert foo.pdf foo.png", with GraphicsMagic: "gm convert foo.pdf foo.png".
2. Look in "top" or "ps" for a "gs" process eating up CPU.

Actual results:

Ghostscript takes ages to convert image.

Expected results:

Ghostscript takes mere seconds to convert image.

Additional info:

The command line of the ghostscript interpreter spawned by ImageMagick includes the flag "-dTextAlphaBits=4".  When invoking ghostscript manually and changing only that flag to "-dTextAlphaBits=1", it completes pretty quickly.

I've found that updating Ghostscript to a newer version fixes the problem as well. I've built and installed the ghostscript-9.10-4.fc20.src.rpm SRPM from Fedora 20.

If you can't reproduce the issue, I can provide a PDF that triggers the problem.
Comment 2 josef radinger 2016-02-18 02:41:59 EST
any progress here?
we are affected as well. the same issue. conversion never ends (we killed the processes after several hours). upgrading did the trick, but we need a supported version.
Comment 3 David Kaspar [Dee'Kej] 2016-06-22 09:24:22 EDT
Hello, I have previously started to solve this issue in the BZ #1302121. I will close this BZ as a duplicate. You can track all the progress there.

Thank you for your understanding.

*** This bug has been marked as a duplicate of bug 1302121 ***

Note You need to log in before you can comment on or make changes to this bug.