Bug 1302121 - "convert" command hangs when converting pdf to png
Summary: "convert" command hangs when converting pdf to png
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ghostscript   
(Show other bugs)
Version: 7.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: QE Internationalization Bugs
Lenka Špačková
URL:
Whiteboard:
Keywords: i18n
: 1268259 (view as bug list)
Depends On:
Blocks: 1289025 1305230
TreeView+ depends on / blocked
 
Reported: 2016-01-26 20:53 UTC by Matt Goldman
Modified: 2016-11-04 08:28 UTC (History)
9 users (show)

Fixed In Version: ghostscript-9.07-20.el7
Doc Type: Release Note
Doc Text:
Ghostcript no longer hangs when converting a PDF file to PNG Previously, when converting a PDF file into a PNG file, Ghostscript could become unresponsive. This bug has been fixed, and the conversion time is now proportional to the size of the PDF file being converted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 08:28:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test.pdf in question (733.30 KB, application/pdf)
2016-01-26 20:53 UTC, Matt Goldman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2550 normal SHIPPED_LIVE ghostscript bug fix update 2016-11-03 14:20:31 UTC

Description Matt Goldman 2016-01-26 20:53:21 UTC
Created attachment 1118609 [details]
test.pdf in question

Description of problem:

When converting a PDF to PNG using 'convert', it hangs. 

Version-Release number of selected component (if applicable):
RHEL 7
ImageMagick-6.7.8.9-10.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Download PDF 
2. Attempt to convert PDF with 'convert test.pdf test.png'

Actual results:
Hangs, no output

Expected results:
Output test.png

Additional info:
Customer was able to get around this using an upstream version.

Comment 3 Bryan Mason 2016-01-26 21:31:39 UTC
The pstack shows that the convert command is actually waiting for the 'gs' command to return.  So this is most likely a problem in ghostscript and not ImageMagick.  I'm moving the components and I'll see if I can determine what gs is up to to cause the problem.

Comment 4 josef radinger 2016-03-02 08:26:07 UTC
affected, too

Comment 5 Bryan Mason 2016-03-08 00:38:54 UTC
According to strace, ImageMagick is executing the following command:

/usr/bin/gs -q -dQUIET -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT \
-dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 -sDEVICE=pam \ 
-dTextAlphaBits=4 -dGraphicsAlphaBits=4 -r72x72 -dUseCIEColor \
-sOutputFile=/tmp/magick-gvr4A3Qr-%08d -f/tmp/magick-FGoe7KZa \
-f/tmp/magick-B-PH4C8T"

/tmp/magick-B-PH4C8T is a symlink to the original file passed to ImageMagick

/tmp/magick-FGoe7KZa is a file containing one space (0x20):
$ hexdump -C /tmp/magick-FGoe7KZa
00000000  20                                                | |

This works (or at least it returns):

$ gs -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT -sDEVICE=pam \
-sOutputFile=test.pam -f test.pdf 
GPL Ghostscript 9.07 (2013-02-14)
Copyright (C) 2012 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1

Adding options fails when I reach "-dTextAlphaBits=4":

/usr/bin/gs -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT \
-dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 -sDEVICE=pam \
-dTextAlphaBits=4 -sOutputFile=test.pam -f test.pdf 

The rest of the command, without "-dTextAlphaBits=4" doesn't hang:

$ /usr/bin/gs -dSAFER -dBATCH -dNOPAUSE -dNOPROMPT \
-dMaxBitmap=500000000 -dAlignToPixels=0 -dGridFitTT=2 -sDEVICE=pam \
-dGraphicsAlphaBits=4 -r72x72 -dUseCIEColor -sOutputFile=test.pam \
-f test.pdf 
GPL Ghostscript 9.07 (2013-02-14)
Copyright (C) 2012 Artifex Software, Inc.  All rights reserved.
This software comes with NO WARRANTY: see the file PUBLIC for details.
Processing pages 1 through 1.
Page 1

So I'm guessing the problem is with "-dTextAlphaBits=4"

Comment 10 David Kaspar [Dee'Kej] 2016-06-22 11:59:46 UTC
Upstream commit that fixes this issue as side-effect of it:
http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=c27113ab96a8010b596

Comment 13 David Kaspar [Dee'Kej] 2016-06-22 13:24:22 UTC
*** Bug 1268259 has been marked as a duplicate of this bug. ***

Comment 27 errata-xmlrpc 2016-11-04 08:28:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2550.html


Note You need to log in before you can comment on or make changes to this bug.