Bug 1268318 - qdrouter on clients needs to handle torn down connections on port 5646
qdrouter on clients needs to handle torn down connections on port 5646
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity urgent (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-02 09:51 EDT by Stuart Auchterlonie
Modified: 2017-02-23 14:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 11:33:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stuart Auchterlonie 2015-10-02 09:51:09 EDT
Description of problem:

Following on from
https://bugzilla.redhat.com/show_bug.cgi?id=1249890

I was mentioned that this issue would affect clients to,
see comments #13, #18, #20, #31, #32

Version-Release number of selected component (if applicable):

6.1.2 plus hotfix from https://bugzilla.redhat.com/show_bug.cgi?id=1249890

How reproducible:

100%

Steps to Reproduce:
1. Have client connected to satellite. Uses port :5646
2. Simulate dropped connection. I used iptables to drop all :5646 
   traffic from the client system
3. Satellite / Capsule side will drop and clean up the connections
   with the hotfix in place, the client side does not.

Actual results:

Client systems still think their connection is open, when it has
been torn down.

Expected results:

Client systems deal with torn down connections to the sat / capsule
and reconnect


Additional info:

Client system: 192.168.160.186 (appear to Satellite at 10.33.1.59 due to NAT)
Satellite sys: 10.33.9.118

Initial State:
- Client:
# netstat -tanp | grep :5646
tcp        0   5956 192.168.160.186:52656   10.33.9.118:5646        ESTABLISHED 14862/qdrouterd     
- Satellite:
# netstat -tanp | grep :5646
...   
tcp        0      0 10.33.9.118:5646        10.33.1.59:52656        ESTABLISHED 18866/qdrouterd 

Add iptables rules:
- Satellite netstat changes to
tcp        0   4597 10.33.9.118:5646        10.33.1.59:52656        FIN_WAIT1   - 
before disappearing completely shortly aftwards.

Client system still has
tcp        0      0 192.168.160.186:53051   10.33.9.118:5646        ESTABLISHED 14862/qdrouterd
Comment 2 Stuart Auchterlonie 2015-10-05 11:33:51 EDT
Faulty testing methodology, going to re-raise with proper data

Note You need to log in before you can comment on or make changes to this bug.