Bug 126840 - i865 driver does not configure properly on Dell GX270
i865 driver does not configure properly on Dell GX270
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 05:03 EDT by Per Steinar Iversen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 16:03:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2004-06-28 05:03:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040116

Description of problem:
After installing FC2 on a Dell GX270 machine then X11 fails to start
after first boot. Reducing the color depth from 24 to 16 allows X11 to
start with VGA resolution. It is not possible to change this
resolution  to anything else.

After some searching it seems this is a known issue with some
chipsets, see:

http://www.chzsoft.com.ar/855patch.html

After installing the 865patch utility X11 works as expected.
It is stated that the problem is fixed with Dell BIOS A04, but this is
the BIOS version on my machine, as reported with dmidecode, so perhaps
the problem still persists.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install FC2 on Dell GX270 machine.
2. Reboot after install - X11 dies.
3. Reduce color depth, get VGA resolution
    

Actual Results:  X11 would start in VGA mode when the color depth was
reduced. It is not possible to change the resolution to something better.

Expected Results:  X11 should have started properly and allowed
something better than VGA resolution.

Additional info:

It seems this is an issue with several common pc makes that uses Intel
embedded graphics.
Comment 1 Howard Holm 2004-07-04 15:00:23 EDT
My Dell Dimension 8600 had this problem as well.  It seems to be fixed
with BIOS A10 for the Dimension 8600 released June 29, 2004.  Although
since the update I have a different Xorg bug (bug 127222) that may or
may not be related.
Comment 2 Mike A. Harris 2004-08-30 18:06:57 EDT
This problem is caused due to buggy Dell BIOS in your system.  The
855patch.html URL contains a very ugly hack to work around the
problem, which is not really acceptable quality to include in the
distribution.  The proper fix is to flash the BIOS to a fixed one
if one is available, as mentioned in comment #1 above, however
from what I understand, the new Dell BIOS is buggy also. Either way,
only Dell can fix their BIOS.

If a proper workaround becomes available in X.Org CVS, it will appear
in a future release of Fedora Core, however only a proper fix will
be considered for Fedora Core updates.

I'm closing this as WONTFIX for now, as there's no known fix for
this available to my knowledge.  I recommend testing the current
rawhide X.Org test release and updating the report to indicate
if the problem has been worked around or not.  If the problem still
exists in current X.Org CVS, you can file a bug report in X.Org
bugzilla to track the issue if you like.  We do not have Intel
chipset documentation however, so we are reliant on those who
do have such documentation to supply a proper cleanly implemented
driver workaround which programs the chipset directly from within
the video driver, in order to consider it for our OS.

Closing as "WONTFIX".

Note You need to log in before you can comment on or make changes to this bug.