Bug 126845 - 'None' doesn't work with gnome.help_display()
'None' doesn't work with gnome.help_display()
Status: CLOSED DUPLICATE of bug 126847
Product: Fedora
Classification: Fedora
Component: gnome-python2 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-28 08:26 EDT by Zoltan Kota
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for help_display (866 bytes, patch)
2004-06-28 08:38 EDT, Zoltan Kota
no flags Details | Diff

  None (edit)
Description Zoltan Kota 2004-06-28 08:26:20 EDT
Description of problem:
'None' does not work as the second argument of gnome.help_display().



Version-Release number of selected component (if applicable):
gnome-python2-2.0.0-4.1

How reproducible:
Always

Steps to Reproduce:
1. yum install pybliographer from Fedora Extra stable repository
2. change line 'gnome.help_display ('pybliographer', '')' to 
   'gnome.help_display ('pybliographer', 'None')' in the file
   /usr/share/pybliographer/Pyblio/GnomeUI/Document.py
3. start pybliographic with the command 'pybliographic' in a terminal
4. Choose Help - Contents

Actual Results:  Yelp gives an error message: 'The selected page could
not be found in this document'

Expected Results:  Yelp shows the Contents page without error.

Additional info:

See the discussions:
http://mail.gnome.org/archives/gnome-doc-list/2004-June/msg00038.html
http://mail.gnome.org/archives/gnome-doc-list/2004-June/msg00040.html

This bug is reported at bugzilla.gnome.org, and there is a fix already
in gnome CVS. 
See: http://bugzilla.gnome.org/show_bug.cgi?id=144976
A package update would be great.
Comment 1 Zoltan Kota 2004-06-28 08:38:17 EDT
Created attachment 101464 [details]
patch for help_display

It is a possible patch. I prepared it according to gnome cvs. Please check it
if it's correct. I couldn't test it yet.
Comment 2 Jonathan Blandford 2004-08-18 16:38:21 EDT

*** This bug has been marked as a duplicate of 126847 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.